HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL360 G5 RAM configuration problems

 
SOLVED
Go to solution
GeoffHH
Occasional Advisor

DL360 G5 RAM configuration problems

Hi,

I've got 2 identical DL360 G5 servers, with 8 PC2-5300 512MB DDR2 ECC modules between them. They all have the same HP spare parts number - 398705-051.

In server #1, it only takes 2 of the 8 sticks, and no others installed into 1A and 3A slots.

In server #2, it only takes the other 6 sticks, in 1A, 3A, 5B, 7B, 2C, 4C slots.

I've verified these slots with the G5 Server Maintenance and User Guide. Swapping any pair of sticks with any other pair of sticks results in the constant beep and all DIMMS lit up on the UID LED panel.

Any other combination of RAM results in constant beep upon POST, and all DIMMS on the UID LED panel are lit.

If all sticks have the same P/N, they should be interchangeable with other sticks with the same P/N, right? I've kept them in their pairs, but was just curious I guess.

Any help appreciated.

Thanks
Geoff
9 REPLIES
GeoffHH
Occasional Advisor

Re: DL360 G5 RAM configuration problems

Hi, it's me again.

After fiddling with the RAM, Server #1 is happily running with its original configuration.

Server #2 has it's original RAM in there, in the same slots as before but is having the same problem as if it had different configuration in there. The pairs may not be matched like they were prior to my fiddling about, but they all are exactly the same (they came with the server!) with the same part number and everything.

Getting really confused. Is there anything I have to 'reset' for the server to accept a RAM configuration slightly different (even something minor like RAM sticks in a pair swapped)? No... right?

Thanks
Geoff
KarloChacon
Honored Contributor
Solution

Re: DL360 G5 RAM configuration problems

hi

looks like MEM conf gets messed up try

clear NVRAM, procedure:
link to locate system maintenance switch, page 74
http://bizsupport.austin.hp.com/bc/docs/support/SupportManual/c00710376/c00710376.pdf


1. Power down the server.
2. Remove the server cover.
3. Locate the System Maintenance Switch, position 6, and move the switch to the "On=Clear NVRAM" position.
4. Power the server back on until Power-On Self-Test begins.
5. After POST has started, power-cycle the server off.
6. Move the System Maintenance Switch back to the "Off" position.
7. Replace the server cover and power on the system. The server will boot normally.

try this with the mem configuration that works and after that insert new DIMMS


also try updating System Rom
regards
Didn't your momma teach you to say thanks!
GeoffHH
Occasional Advisor

Re: DL360 G5 RAM configuration problems

Thanks for the prompt reply. I noticed a sentence in the manual you provided:

"CAUTION: Clearing CMOS and/or NVRAM deletes configuration information. Be sure to properly configure the server or data loss could occur."

Is this anything to worry about? I have a fully operational OS and software on there I'd like not to jeopardise.

As far as I'm aware, it shouldn't mess with the RAID array configuration, right?

Thanks
Geoff
KarloChacon
Honored Contributor

Re: DL360 G5 RAM configuration problems

hi

you know what it's the first time I see that
kinda scary message since I've done it lot of times causing no problems like data loss no no

no worries go ahead

regards
Didn't your momma teach you to say thanks!
GeoffHH
Occasional Advisor

Re: DL360 G5 RAM configuration problems

Unless I'm doing something wrong, it didn't work. I still couldn't get Server #2 to accept its own RAM with this technique.

After setting the jumper 6 to On, how far along the boot process should I wait before powering it down again? Maybe I'm not waiting long enough?

With Server #1 to accept the RAM from Server #2, after changing the Switch to On, I waited until after the ProLiant logo screen, then it said some stuff then "Advanced ECC Memory" or similar, then I powered down. I changed it back to off, added the extra RAM and it beeped upon boot and displayed nothing on screen.

With Server #2 to accept its own RAM (6x 512MB modules), it just beeped upon boot and displayed nothing on screen after ~10-15 sec so I powered down and changed the switch back to Off.

Am I waiting long enough?

Thanks
Geoff
KarloChacon
Honored Contributor

Re: DL360 G5 RAM configuration problems

leave SW 6 ON for 1 minute


for the second server try to get a configuration where you get video - clear NVRAM and start adding memory modules

regards

Didn't your momma teach you to say thanks!
GeoffHH
Occasional Advisor

Re: DL360 G5 RAM configuration problems

I got one of the servers working well, but the other refuses to boot with any combination of RAM - even it's original configuration.

I called HP support, and arranged a technician to come out and have a look. They're under warranty, so it's all good.

He's bringing a new mainboard with him as well, so fingers crossed we can work it out.

Thanks for your help! The HP phone staff suggested clearing NVRAM as well, so you were definitely helpful!

Thanks again
Geoff
KarloChacon
Honored Contributor

Re: DL360 G5 RAM configuration problems

ok ok

let me know how it was after that part replacement

bye
Didn't your momma teach you to say thanks!
GeoffHH
Occasional Advisor

Re: DL360 G5 RAM configuration problems

The HP service technician came today and ended up replacing the mainboard. It appears to be working well now. He also updated all firmware as well.

He'll come again tomorrow to service the second server, with what I predict the same result.

Thanks again
Geoff