ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL360 G7 no snmp through iLO

JBruyet
Frequent Advisor

DL360 G7 no snmp through iLO

Good mornin all,

I have a DL360 G7 running as a VMware host. I have configured snmp through the ESXi software and that is working fine--I can run an snmpwalk and I'm pulling the information. However, when I run an snmpwalk through the iLO port I get this:

Timeout: No Response from 192.168.2.57

I've tried running this with snmp pass-thru enabled and with it disabled but no joy either way.

Unfortunately the rest of my hosts are G9s so I don't have anything to compare the setting to. I did have some G7 machines as VMware hosts a few years ago and I was pulling information from them through Nagios which uses snmp.

Does anyone have any ideas, suggestions or recommendations on how I can get snmp configured so I can get the information I'm after? This is so my Observium server can see into it and alert me when problems arise.

Thanks,

Joe B

5 REPLIES
BOYAN BIANDOV
Regular Advisor

Re: DL360 G7 no snmp through iLO

I am on almost the same box - ProLiant DL380p Gen8

All I had to do is populate the public read community string; then SNMP walking just started working

The SNMP Alert Destination(s): on the picture is NOT relevant to snmp-walk; it's for traps.

snmp.png

JBruyet
Frequent Advisor

Re: DL360 G7 no snmp through iLO

Thanks Boyan. I just looked and I see I neglected to mention that this server is running iLO3. I checked this morning and my firmware is at the current version. Anyone else? 

Thanks,

Joe B

BOYAN BIANDOV
Regular Advisor

Re: DL360 G7 no snmp through iLO

You made me curious so I did few tests; I have several boxes running iLO3 v1.88 - results. iLO on the windows boxes just passes SNMP throuigh to Windows so when I snmp-walk the iLO IP I get the response from Windows OS.

On ESXi however when I hit the iLO IP with snmp walk it times out even though ESXi itself is configured and responds fine when snmp walked.

The iLO3 config is pretty simple; as shown here. I think it has something to do with what OS is running on the iLO3 box:

ilo3.png

JBruyet
Frequent Advisor

Re: DL360 G7 no snmp through iLO

Yep, that's my interface. Since your ESXi is giving you the same results I'm getting I suppose I should just call it a day. Although it does make me wonder why it won't work...

Thanks,

Joe B

JBruyet
Frequent Advisor

Re: DL360 G7 no snmp through iLO

I connected up another ESXi host running on a ProLiant DL360 G7 and it has the same issue -- snmp works just fine for the ESXi but the pass-through isn't working.

Sigh,

Joe B