ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL360 Gen9 Server Platform Services Firmware requires update

Ruben_Herold
Advisor

DL360 Gen9 Server Platform Services Firmware requires update

hi,

 

I have here a fresh updated DL360 Gen9 with this Firmware:


Firmware Name  Firmware Version Location
HPE Ethernet 1Gb 4-port 331i Adapter - NIC 20.8.41 Embedded
iLO 2.55 Aug 16 2017 System Board
Intelligent Platform Abstraction Data 25.13 System Board
Intelligent Provisioning 2.70.75 System Board
Power Management Controller Firmware 1.0.9 System Board
Power Management Controller FW Bootloader 1.0 System Board
Redundant System ROM P89 v2.56 (01/22/2018) System Board
SAS Programmable Logic Device Version 0x02 System Board
Smart Array P440ar Controller 6.30 Embedded
System Programmable Logic Device Version 0x2C System Board
System ROM P89 v2.56 (01/22/2018) System Board

On Post and in the Integrated Managment Log I see every boot:

POST Error: 261-Server Platform Services Firmware requires update. Action: Please run the Server Platform Services Firmware Flash Component to update this firmware.

 

I can't find any newer Firmware for this box? All stuff is on fresh Firmware.

 

 

7 REPLIES
Torsten.
Acclaimed Contributor

Re: DL360 Gen9 Server Platform Services Firmware requires update

There are multiple separate firmware downloads around the intel stuff (ME) available.

these are some files I have:

 

firmware-iegen10-0.1.4.4-1.1.x86_64.compsig
firmware-iegen10-0.1.4.4-1.1.x86_64.rpm
firmware-iegen10-0.1.5.2-1.1.x86_64.compsig
firmware-iegen10-0.1.5.2-1.1.x86_64.rpm
firmware-spsgen10-04.00.04.288-2.1.x86_64.compsig
firmware-spsgen10-04.00.04.288-2.1.x86_64.rpm
IEGen10_0.1.4.4.signed.bin
IEGen10_0.1.5.2.signed.bin
IEGen10_0.1.5.2B.signed.bin
INTEL-ME-Bug-steps.txt
recovery-set-update-100.74.iso
SPSGen10_04.00.04.288.signed.bin

 

 

Please go to ILO firmware overview page and take a screenshot.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Ruben_Herold
Advisor

Re: DL360 Gen9 Server Platform Services Firmware requires update

hi Torsten,

your files are all for gen10 only. Here we have an gen9 server.

Attached the screenshot you requested:

Ilo-docker.jpgWe have the ilo running on ipv6 only

ilo-docker1.jpg

Torsten.
Acclaimed Contributor

Re: DL360 Gen9 Server Platform Services Firmware requires update

Sorry, yes this was Gen10.

How about this?

https://support.hpe.com/hpsc/doc/public/display?docId=c04849981

 

For Gen8 this error pointed to the power management controller firmware.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Ruben_Herold
Advisor

Re: DL360 Gen9 Server Platform Services Firmware requires update

hi,

I have tested the v4 updates on linux (rhel) and on windows ( 2016). They don't work.

The installers start and run endless ( stop them after a few hours). Seems that they are not working current firmware releases. 

Ruben_Herold
Advisor

Re: DL360 Gen9 Server Platform Services Firmware requires update

On Linux and Windows looks like the same. This screenshot was taken 10 hours after starting the flash process:

 

ilo-docker2.png

Torsten.
Acclaimed Contributor

Re: DL360 Gen9 Server Platform Services Firmware requires update

I don't know what the problem is, but maybe a needed component already came with an earlier BIOS for example but the system needs a complete power cycle (pull the plugs) to recognize it.

Did you try this already?


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Ruben_Herold
Advisor

Re: DL360 Gen9 Server Platform Services Firmware requires update

hi,

what we did:

        * powercycle

        * switch from efi to legacy boot

        * flash all components on linux and windows

 

no changes so far. What makes me wonder is:

 

[root@localhost old]# ./cpqsetup
Flash Engine Version: Linux-1.5.3-13

Name: Intel Xeon Processor Xeon E5-2600 V4 Software Upgrade Online Flash component for Linux - HPE ProLiant Gen9 servers
New Version: 3.1.3.021

Current Version:

The software is installed but is not up to date.

 

But It can't flash it. It starts and run endless on windows and linux. On efi and non efi. Looks for me that there is something wrong in the flash process.