ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL360: freeze after changing a kernel option in the Grub boot menu

 
flaf
Occasional Visitor

DL360: freeze after changing a kernel option in the Grub boot menu

Hi,

 

Here is the model of my server: HP Proliant DL360 Gen9. The bios-UEFI firmware is updated (05.06.2015). I have kept the UEFI enabled but I have this:

 

  Server Security => Secure Boot Settings:

      Current Secure Boot State => Disabled
      Secure Boot Enforcement   => Disabled

 

Then, the technical support tells me to install this image of Ubuntu Trusty. Indeed I have absolutely no problem with the installation. I can reboot the server, I have a network UP, in brief all is OK.

 

But, one day I wanted to make some IO benchs. In this case, I'm used to limit the RAM of the server before doing the bench. So I reboot the server and, during the Grub menu, I type "e" to edit the default grub menu and just append a this kernel boot option "mem=512m". After that, I type F10 to boot the server with my modified Grub menu. And after that, total freeze of the server. I have a black screen, with no message. The linux kernel is not loaded, the server is blocked before to load the kernel. Even with "Ctrl+Alt+Suppr", impossible to reboot the server. I have to make a hard resert to reboot the server.

 

In fact, if want to change any option of the kernel in Grub, I have this total freeze. For instance I have tried too "ipv6.disable=1", I have exactly the same problem. I have tried too to change the boot option with the "/etc/default/grub" file (and after I run "update-grub"). I have exactly the same problem (except that, in this case, the default grub menu is definitely changed and I can't reboot the server at all).

 

I have contacted the technical about this problem and this answer was : "I have analyzed the Active Health system of your server, I'm sure that the harware is OK. Here, the problem concerns the OS. I prefer that you contact the Ubuntu support".

 

Personally, I have big doubts concerning this conclusion. Bugs about the bios-UEFI already exist (for instance this nice bug) and I don't understand why we can be sure that my problem is not a bug of the bios-UEFI too?

 

Has someone already noticed this kind of problem on this server?
Do you have suggestions concerning my problem?

 

Thanks in advance for your help.

François Lafont


PS: indeed, if I set the bios to "bios legacy" (ie I disable UEFI) and if I make a install in this condition, I have no problem and I don't have this freeze. But I would like to understand (and solve) the problem above with bios-UEFI. I'm a little surprised by the answer of the technical support. But I'm maybe wrong...

 

PS2: I have already appended the kernel option "mem=512m" in the default grub menu a ton of times without any problem and of course I do no syntax error during this step. ;)

2 REPLIES
olc95
Occasional Visitor

Re: DL360: freeze after changing a kernel option in the Grub boot menu

Same problem here with rhel 7.1:

1) modify the option in grub bootloader, adding, say: "mem=256M" to the linuxefi row

2) ctrl+e in order to apply and boot

then bang: the server hangs. A hard reset is mandatory.

flaf
Occasional Visitor

Re: DL360: freeze after changing a kernel option in the Grub boot menu

Hi,

 

olc95, thanks you for your message that confirm to me the possibility of a bug concerning the firmware of the bios-UEFI. I have tried too Redhat Enterprise 7.1 and I have exactly the same problem. I reported this problem to the HP support with these new tests but I have currently no answer (and I'm afraid of never having any answer).

 

Are there other people who have this problem?
Bye.