ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL360 gen 9 and videocards

leon78
Frequent Visitor

DL360 gen 9 and videocards

Hi!

I try to setup videocards in the server DL360 gen 9, but I have trouble.

I used cards:

1. Asus Geforce 210-1GD3-L

2. ATI Radeon R7 240

3. AMD Radeon R5 200.

I used OS:

1. Windows 2008 R2 server.

2. Windows 7 64 bit

I have same probem:

The cards in Device Maneger have warning icon and code error 12

https://technet.microsoft.com/en-us/library/cc732199(v=ws.10).aspx

I do not have any problems with the cards and OS with ML350 gen 8 

9 REPLIES
Suman_1978
HPE Pro

Re: DL360 gen 9 and videocards

Hi,

 

DL360 Gen9 being a Rack Server, it has few options to upgrade or add new cards.

If you see the Code 12 Diagnosis "Two devices have been assigned the same input/output (I/O) ports, the same interrupt, or the same Direct Memory Access channel. The assignment was made by either the basic input/output system (BIOS), the operating system, or a combination of the two."

 

I would recommend to remove any other cards that are installed in the server and see if the BIOS/System Board can allocate the resources.

 

Other troubleshooting steps that you could try:

Clear NVRAM from System Maintenance Switch.

Reinstall a compatible OS on this server after adding the video card, so that OS allocates the required resources during fresh install.

See if a BIOS update fixes this issue.

 

ML series is a Tower server and has quiet a lot space for expansion.

 

 

Good Luck.

Thank You!
I am a HP employee
__________________________________________
Was the post useful? Click on the white KUDOS! Thumb below to say Thank You!

Useful Links for ProLiant Servers

 

Self Solve Options for ProLiant Servers

leon78
Frequent Visitor

Re: DL360 gen 9 and videocards

Hi,

 

Thank you for your help,

but we have only one video card, we dont use other cards.

We updated BIOS and other firmware.

We installed OS after installation of video card.

We updated OS.

We will try to "Clear NVRAM from System Maintenance Switch"

nikitakuz
Visitor

Re: DL360 gen 9 and videocards

Hello,

Unfortunately we couldnt solve our problem and of course we used all your advices.

I put some screenshots for understanding our problem. 

As you know our server is DL 360 Gen9 and for example Video Card NVIDIA GeForce 210, our RAM 16 Gb.

So is it possible that RAM 16 Gb is not unsuitable for this video card.

And also we found some information about DL 360 GEN10 that this server can work normally only with HP GeForce Quadro 2200 and HP GeForce Quadro. Is it truth?

Another information about this problem  is IRQ. I also put  screenshots with this. As you see  NVIDIA GeForce 210 has the same IRQ as Base system device (PCI) 0x0000000(10).  Is it normal?

 

leon78
Frequent Visitor

Re: DL360 gen 9 and videocards

Hello!

 

Today we installed new card HP Quadro K4200 (J0G90A).
But problem is not solved still.
What do we must do?

leon78
Frequent Visitor

Re: DL360 gen 9 and videocards

I see, it is not a new problem.

http://h30499.www3.hp.com/t5/ProLiant-Servers-ML-DL-SL/ML150-G5-possible-BIOS-bug-with-add-on-pcie-video-card/m-p/4242409#M81766

16Gb RAM in our servers. But we tried videocards with 2Gb.

But for gen 8 we dont have the problem.

Please, we need help. HP support in my country cannot help us.

Torsten.
Acclaimed Contributor

Re: DL360 gen 9 and videocards

It is maybe better to look out for a supported card with this server:

 

 

Section

 

HP Computation and Graphics Accelerators
 
in
 
 
 
 
But maybe you just have a problem with drivers for your card?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
nikitakuz
Visitor

Re: DL360 gen 9 and videocards

Hello again,

 

We are very dissapointed by this Server DL 360 GEN9. We have done all that is possible, all methods, all advices that were given by the HP technical solution consultant. The problem is not solved.  Nobody can help us???? Come on HP, can help us to fix this problem. 

I will try to explain again our problem. We installed Windows Server 2008 R2 via HP Intelligent Provisioning on Server DL360 Gen9. In the result all drivers are normally except videocard (device manager will show a yellow exclamation sign for that particular pcie slot with the following message: "This device cannot find enough free resources that it can use. (Code 12)"(Screenshot №1) .  

Also I can say that we used 5 videocards:

                        1) NVIDIA GEFORCE 210 (1 GB DDR 3)

                        2) AMD Radeon R5 200 Series ( 1 GB DDR 3)

                        3) NVIDIA  Quadro K600 ( 1GB DDR 3)

                        4) AMD Radeon™ R5 230 ( 2 GB DDR 3)

                        5) HP Quadro K4200 (4 Gb DDR 5)  (RECOMENDED by HP) 

During the all time we tried to reinstall OS and of course before installation of OS we put videocard. Even I can say that we have available more than one server DL 360 Gen9, actually 5  servers and we have done this procedure on all of the servers. Result is the same :( 

Now a little bit about our attemps to fix it.

  1. We reinstall OS via a differents methods many times (including via HP Intelligent Provisioning )
  2. We reinstall all drivers many times. Drivers were downloaded from the official HP website. (http://h20564.www2.hp.com/hpsc/swd/public/readIndex?sp4ts.oid=7252838&swLangOid=8&swEnvOid=4064)
  3. Reset the bios to deffault setting.
  4. Clear NVRAM from System Maintenance Switch.
  5. Tried to disable the onboard video in device manager in safemode and rebooting.
  6. We tried to set in BIOS CONFIGURATION VIDEO OPTIONS:  [Add-In Video Enabled, Embedded Video Disabled]
  7. System Configuration→BIOS/Platform Configuration

    (RBSU)→System Options→Serial Port Options→Embedded Serial Port and press Enter.  AND the same with virtual Serial Port.

  8. In device manager:  View → Resources by connection, also we can see all PCI Bus with errors (Screenshot №2). First at full I deleted PCI Bus with the error on the branch of input/output (I/O) ports and wait untill computer  find a new drivers then push the power button.  Now Turn on the computer, wait untill all drivers were installed and then again open the DEVICE MANAGER : View → Resources by connection →Memory →Deleted PCI Bus with error then again wait untill computer  find a new drivers then push the power button. Again turn on the computer, repeat all procedure but now deleting DMA and restart the server. All drivers  had to set without errors, but I saw the same situation.  This information I found on some forums ,  My problem is not fixed . 
  9. Of course we update the bios too.

THE RESULT : WE CANT FIX OUR PROBLEM!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

 

SOME SPECIFICATIONS of server in picture "specification".

 

HELP US! We dont have anough time :(

 

Torsten.
Acclaimed Contributor

Re: DL360 gen 9 and videocards

I can't open the drivers page you linked above, but I doubt you will find nvidia drivers for 2008 r2 for this geforce 210 card there. Even nvidia has no 2008 drivers, but someone told win7 drivers should work fine.

What drivers did you use?

Unfortunatelly it is a bit hard to read the screenshots ... ;-)


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
leon78
Frequent Visitor

Re: DL360 gen 9 and videocards

New BIOS, sent by HP, helped us.

Even cheap videocards are suitable, but not all.

Asus Geforce 210-1GD3-L is OK.