ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL380 G1 general questions...

Jman594
Advisor

DL380 G1 general questions...

I have just finished building a DL380 G1 with the following components:
2 - 1Ghz Cpu's
2 - 256Mb and 1 - 128Mb ECC RAM
4 - 18.2GB U3 10K (in the 4X1 bay)
2 - 9.1GB U3 15K (in the 2X1 bay)*
and basically a standard DL380 from there.

I know almost nothing about servers and/or server operating systems. I am taking a MCSE class to hopefully gain a full understanding;
however, I need to get this server up and running.

The person that I bought this machine off of (minus the 2X1 LVD drive cage, any drives, memory, processors, or software)informed me that I could run the OS off the 15K drives and use the other 4 for a RAID 5 Array. I also, through a bit of researh found that I need SmartStart 5.50 to begin and through this forum, have found the link to that.

Now for the questions:
1. I have installed the 2X1 drive cage and have connected the small ribbon from it to the other drive bay. Since both are U3, and I have only one SCSI cable jack on either one, Should I use the SCSI cable from SCSI port 1 to connect to the 2X1? It is not a point-to-point SCSI cable because it has 2 connectors and a termiation.

2. I have obtained a copy of Microsoft Server 2003 Standard edition R2 via dreamspark. will this OS work with my hardware? (man, I really hope so)

3. I want to run a mirror on the OS drives (RAID 1?) and a RAID 5 on the other ones. Any special hardware or configuration to consider?

4. Are there any good resouces to find a walkthrough for the smart start? All I really want is to be able to get to a clean Windows OS and have all my hardware configured properly so that I can start my MCSE class.

5. Am I in over my head? :-Þ

I have looked through these forums and haven't quite seen anything specific to my situation. I appriciate your time in helping me. From what I've seen, you guys know your stuff.

Thanks so much,
Josh
11 REPLIES
Blazhev_1
Honored Contributor

Re: DL380 G1 general questions...

Hi Josh,

Here are 2 guides about the server about hardware configuration :

http://bizsupport.austin.hp.com/bc/docs/support/SupportManual/c01129673/c01129673.pdf

Check page 42 for cable routing and connections.

!!! and check page 128 here :

http://bizsupport.austin.hp.com/bc/docs/support/SupportManual/c01127227/c01127227.pdf

"Connect the signal cable, supplied in
the option kit, from the option cage
backplane to the standard cage backplane"


2. Windows 2003 SE, R2 is supported on the server , you can check the OS Matrix :

http://h71028.www7.hp.com/enterprise/cache/461235-0-0-0-121.html

3. If you connect the HDDs(don't know if you have the 2nd cable for the optional cage) , then this is all you need.
Then you can either
- boot From Smartstart->Maintain server->Array configuration utility- click controller-create array - click array - create logical drive, select 2 HDDs, select raid 1/1+0- click save, apply->again for the other four drives...
- while initialising the controller in POST, press F8 , create log drive and so on...

4. You can boot smartstart, there should be a button Clear All or something like that(haven't used 5.50), then you can go in maintain server->deploy server->choose OS->partition->put win Cd in and follow install...

5. :)

If you have specific questions, hope we can help...

Regards,
Pac

Blazhev_1
Honored Contributor

Re: DL380 G1 general questions...

Hi again,

You don't need smartstart, but it is simpler with it.
As far as I remember for 70-290 you will have to install windows in 3-4 different ways(sysprep, manual, unattended, from RIS/network and so on), so it will be a good to make a slipstream CD later with the OS and the RAID driver in it, since there are no USB ports and floppy options with this veeeery old server.

Jman594
Advisor

Re: DL380 G1 general questions...

I have booted the server, downloaded and burned the ISO, and put it in the drive tray.

I cannot get passed this message:

Non-System disk or disk error
replace and strike any key when ready

I have downloaded and put to 1.44MB diskettes (4) the compaq system configuration utility and it will still not go passed the screen mentioned above.

I think that the POST may be working fine as it shows me the RAM, CPU's and 1 logical drive.

on the post screen, it asks me to press F1 to continue or F10 for system partition utilities. both lead to nowhere.

Please help. All of the documentation that I can find doesn't get me passed this frustrating part. Thanks!!!

oh and the wiring I think was right, because it can see all the drives.
Jman594
Advisor

Re: DL380 G1 general questions...

Oh, and I'm sorry, which logical drive configuration should I use?

45.5 GB RAID 5 drive, parity, fault tolerant, no online spare

36.4GB RAID 5 drive, parity, fault tolerant, with online spare

27.3GB RAID 1 drive, mirrored, fault tolerant, no online spare

18.2GB RAID 1 drive, mirrored, fault tolerant, with online spare

54.6 RAID 0 drive, no fault tolerance
Blazhev_1
Honored Contributor

Re: DL380 G1 general questions...

Hi,

you must change the boot order, so the server tries to boot form CD first, not from HDD like in your case.

With F10 go in System config utility?!? and then check the menu where uis the boot order, choose to boot from CD first.

Then fir the raid config :

OS -2HDDs x 9 GB in RAID 1 = 9GB, mirrored, fault tolerance, no on;line spare

2nd log drive : 4x 18.2 HDDs = 54.6 GB RAID, parity, fault tolerance, no online spare... not sure if you have such options , but this is what should be...

Jman594
Advisor

Re: DL380 G1 general questions...

the machine does the post, then:

1. initializes the integegrated smart array controller (ver1.42) 1 Logical drives

2. press F10 to run the option rom based array configuration utility or press ESC to skip

3. Press F1 to continue or press F10 for system partition utilities.

for # 3, this takes me to the non-system disk error

for #2, F10 lets me access the option rom config for arrays and gives me the option to delete the logical drive configuration or exit.

detected logical drive configuration
45.5GB RAID 5 drive, fault tolerant with no online spare

and then shows me the physical drives assigned.

I have tried to take out the 2 9.1GB 15K's in 4 and 5 and changed the logical drive configuration to 18.2GB raid 1, with no avail.

There has to be something that I can boot from. I have tried smartstart 5.50, 7.00, and my Server 2003 Standard R2 disks and nothing works. I have also taken out one of the processers and vrm. Should I try and recable it to eliminate the 2X1 drive cage?

I have no other resources beyond this forum so I would defanately appricate all the help I can get!!!
Jman594
Advisor

Re: DL380 G1 general questions...

Ok, I've gotten a little further.

I have set the jumper switch next to the LED's (#6) to on.

this gives me the error 177-config not complete
controller order not setup

I then insert the 1.44MB diskette for the system config utility

It then loads the system config utility and starts the process of auto configuration.

configuring hardware, asking for the primary OS, loading config files...

I'll update as to where I am in the configuration as I go.
Jman594
Advisor

Re: DL380 G1 general questions...

When I load the first 3 of the 4 bootable floppys from winser2000 (don't ask where I got it :-Ã ) it is doing everything as expected during an install. When I insert the fourth one, about 50% of the way through, it flashes I/O error and then it says that CDROM.SYS could not be installed and that the install process needs to be aborted. Off the windows server 2000 cd there are two bootable disk creation programs, one that says bootdisk and one that says bootdisk32 (or something like that) and I used both to try and do this.

Is this a concern with my MB or is it a problem with my CD-ROM drive? or firmware, or whatever. I will try and get the exact error codes when I get back to my server if you need that info.

Thanks again!!
Jman594
Advisor

Re: DL380 G1 general questions...

Well, chalk it up to faulty hardware. The CD-Rom drive is crap. So, what I did was take it apart and wedged somthing in the switch that tells it that the tray is closed and left the tray extended to run the cd's and it worked. I've got one ordered so I won't have to do this for long. Thanks for your time all!!!
Blazhev_1
Honored Contributor

Re: DL380 G1 general questions...

Hi,

unfortunately couldn't help you a lot, but this is really old machine and haven't seen such.Glad to hear you managed to get it running :)

Pac
Jman594
Advisor

Re: DL380 G1 general questions...

found that the CD-ROM was broken. Replaced it and that was that!!!