ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL380 G3, Issues installing Win2003 using iLO and virtual media

 
Scott Pease_4
Occasional Advisor

DL380 G3, Issues installing Win2003 using iLO and virtual media

Trying to install Win2003 to a new DL380 G3 using the iLO Advanced + virtual CD.

Using SmartStart 6.4, I can get the server to come up, run all thru smart start, and get to the point where I put in the Win2k3 CD and it shows that it's copying files to the system.

Then it reboots, I remote the CD from my drive, and so far 1 of 3 things happens:

1) System goes thru initial post and then I get a black screen that didn't go away after 2 hours - I assumed it was hung ;)
2) 1 time it ACTUALLY went thru the next step in the process where it shows actually copying the windows install files to the system then reboots and SHOULD have started the actual windows setup configuration - it hung again.
3) 1 other time, it rebooted and threw up a General Protection Fault after post - ouch.

Not sure where we've gone wrong. It sure seems like the whole point of having virtual CD capability with the iLO SHOULD let us build this server remotely. It even seems like it's working, right up until that reboot after copying the windows install files off the CD for the first time... then it just seems to die. Any suggestions, ideas, pointers to a whitepaper I missed somewhere?
20 REPLIES
Eric_76
Regular Advisor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

have you tried building it via local cd?
just to eliminate that part..

somehow it is sounding like it is a memory issue tryit with minimal memory and if it fails try the other memory.

you did install the array controller driver during windows setup right?? F6.F6.F6


Scott Pease_4
Occasional Advisor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

I'd try local, but I'm in Chicago and this server is in London (and 2 others site in New Delhi & Bangalore). As much as I'd love to rack up the frequent flyer miles, local access isn't an option at this point. :(

I also did try doing an install of Win2k3 w/out the smart start CD, but it also hung when I tried to give it the correct disk with the drivers. I'm going to try and make a new image of that floppy disk and give it another go today I think, we'll see.
Prashant (I am Back)
Honored Contributor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

Hi,

Is the firmware for the ILO is updated.

HP recommends upgrading iLO firmware to version 1.15 (or later) on these servers, and iLO firmware version 1.10 is available from the following URLs:

* Options ROMPaq Firmware Upgrade Diskette for Compaq Integrated Lights-Out Management Controller Version 1.10 - SP19835

* Firmware Upgrade Image for Compaq Integrated Lights-Out Management Controller Version 1.10 - SP19836 (binary image)

Meanwhile i am checking on more information.
The server is installed where in indis.

Regards,
Prashant S.
Nothing is impossible
SAKET_5
Honored Contributor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

Hi,

Just a correction to the previous post, the latest iLO FW version is 1.55. Please also be aware that FW versions below this on the iLO have a well known security vulnerability (port zero attacks)..You can read all about this at AusCert.

So, please update your firmware to the
latest V1.55
Confirm that the speed/duplex on the Network Interface of the iLo is forced/duplex from switch and the card both end.
Confirm that you are running the required Java Plug in for the ilo i.e. the correct version. This has often lead to performance frustrations!!!
Go through the graphical performance enhancements tricks for the ILO.

I wish you could use the TermSvcsPassThrough for iLOs for the OS install ;)

Hope it was of help and don't forget to assign points:)

Regards,



Scott Pease_4
Occasional Advisor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

Actually am running 1.55 firmware in the iLO and current P29 (may 2004) BIOS for the DL380 G3. Still validating everything else, but looks like all firmware is fully up to date...
wayne_82
Occasional Advisor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

look at microsoft article referring to virtual media q294820, also have you tried to start install using smart start cd, because the o/s files are then loaded to the local hard drive, and not reading virtual media at that time.
Prashant (I am Back)
Honored Contributor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

Hi,

What about mannual installation not using smartstartcd. does it changed anything.

Regards,
Prashant S.
Nothing is impossible
Scott Pease_4
Occasional Advisor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

i'm in the process of building a new floppy image with the 642 controller card drivers on it to try booting the system to the win2k3 iso I have, then have it use the new 642.img to see if I can get it pull the correct controller drives and see the logica drive I've setup and install to that. So far it's hung when I've tried, but it might be the img I made yesterday (was having issues with both the "Create disk image" thru the ilo and with dd). We'll see I guess? :)
Scott Pease_4
Occasional Advisor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

Okay, update: after it ran thru the "Windows setup is copying files to your hard disk" successfully, the system immediately rebooted, then when it came up the 642 reported "valid data found in the array, it will be written to disk" message, and after it finishes the check on all the controllers, I get... (including actual text of full error since who knows, maybe someone from HP is reading this and can actually figure out what's going wrong based on the actual error message)



TRAP 0000000D == General Protection Fault ==

tr=0028 cr0=00000011 cr2=00000000 cr3=00000000
gdt limit=03FF base=00017000 idt limit=07FF base=00017400


cs:eip=0008:00500006 ss:esp=0010:00061FE8 errcode=1334
flags=00010057 Cy Zr IntDis Down TrapDis
eax=0000110C ebx=00402729 ecx=00001618 edx=534D0040 ds=0010 es=0010
edi=00471650 esi=00061D68 ebp=00061FF0 cr0=00000011 fs=0030 gs=0000




Then the system just completely hangs, nothing more. I can reboot and start the entire process, but this is as far as I've ever gotten.

Current system specs, just in case it helps:
-> DL380G3 (just purchased in last week)
-> Running BIOS P29 from 5/1/2004 (v.4.07)
-> iLO running firmware v 1.55
-> 642 controller set as boot controller, 1 logical drive configured (mirror set of 2 x 36G U320 15krpm drives), controller running firmware v 1.92A
-> attempting to install using valid ISOs of SmartStart 6.4 and Windows 2003 using machine on local LAN (same office as server being built)
Prashant (I am Back)
Honored Contributor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

Hi,

Try restarting the server then check again.

Regards,
Prashant S.
Nothing is impossible
Scott Pease_4
Occasional Advisor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

same result after 4 reboots now :(
Prashant (I am Back)
Honored Contributor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

Scott

All the server respond with same erroes since you have servers in diff location.

Where do you have your server india (Banglore)

Regards,
Prashant S.
Nothing is impossible
Prashant (I am Back)
Honored Contributor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

Hi,

Does the mannual installtion worked on those servers. have any one tried . Because we need to concentrate it is due to ILO or due to some problem with the server.

Regards,
Prashant S.
Nothing is impossible
Rahul Sharma
Frequent Advisor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

What is the amount of memory in the box. Is it possible to bring the server to minimum memory required by Win2k3. say around 512mb and then try installing the win2k3.
Scott Pease_4
Occasional Advisor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

1) What manual installation? I've tried booting to Win2k3 CD ISO as well, it dies when I try to switch from virtual CD to virtual floppy. System just hangs and never gets beyond trying to pull in the drivers. Win2k3 CD itself lacks correct drivers to detect any drives on the 642 card, it just runs thru it's inital setup and then nicely tells me that there are no hard drives detected in the system and that it will now reboot for me. :)

2) System has 2GB of memory, again, I'm in Chicago, the server I'm working on now is in London - not feasible to change memory.

Rahul Sharma
Frequent Advisor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

you need to strip down the memory. As I also had a hard time with similar server. I was trying to scripted built on server and I had to bring down the server to its minimum hardware config. start the server with a smart start and then do manual installed on that box.for some reason 2 gigs of memory is not understood by the system at the time of installation. once the system is up and running you can push back the memory. Arrange for someone to be your hands and eyes and try this out.
Prashant (I am Back)
Honored Contributor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

hi,

What i can help you with is if it is india i can get it verified locally on next working day.

Regards,
Prashant S.
Nothing is impossible
kcpant
Trusted Contributor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

hi,
As suggested by some other friends, it seems a problem related to memory. You have to replace the memory or use lower memory than present.

regards,
PreSales Specialist
paulo baptista
Occasional Contributor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

I know with RILO II cards.. the 380s have issues with Virutal Media..

Check out..
http://h18013.www1.hp.com/products/servers/platforms/usb-support.html

and

http://h18013.www1.hp.com/products/servers/management/riloe2/server-slot-matrix.html

maybe related to iLo...

Take care.

Paulooo
Scott Pease_4
Occasional Advisor

Re: DL380 G3, Issues installing Win2003 using iLO and virtual media

Got it working, but not by removing memory or anything else. None of that actually worked, so still never managed to get it working w/Smart Start.

However, I DID find a willing vict...errr... volunteer ;) in the London office that could extract the drivers for the 5x/6x controller to a floppy and put it in the server for me. Once I had that, I was able to just do a bare install of windows 2003, F6 to use the drivers on the floppy, and after that it all worked wonderfully.

The smart start process would have been nice, but in the end, we got the server built and HOPEFULLY have a repeatable process for building 'em remotely. Thanks for all the ideas and suggestions, and I'd still be interested to hear from someone at HP to see if they can reproduce the same errors, or have any idea what the GPF was caused by (we still saw it after removing memory, etc). Oh well...

:)