ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL380 G3 Netware stops communicating

 
Patrick Schmidt
Occasional Visitor

DL380 G3 Netware stops communicating

I have several DL380 G3 servers that will suddenly just stop communicating. No abend, no errors, the server is just out of touch. I can't ping the server and I can't ping from the server. All I can do is reboot. There is a Novell TID on the subject that tells me to update to the latest driver. I'm on the latest BIOS, NIC drivers, PSP. HP Support suggested I set my minimum packet receive buffers to a higher number, which I did to no avail. Novell support no help. Any suggestions?
4 REPLIES
Ryan Goff
Valued Contributor

Re: DL380 G3 Netware stops communicating

Hi Patrick,

Please try the following:

-disable hyperthreading: Press F9 on startup to enter RBSU, goto Advanced, goto Processor Hyperthreading and select Disable, save and exit
-disable USB, COM and LPT ports if you are not using them to free up IRQ's for your devices
-install the latest network driver: HP NC10xx/67xx/77xx/150x/320x/324x/325x/326x Gigabit Ethernet NIC Driver for NetWare version = 8.56 cp005617.nlm
-if you are using teaming, please try disabling the team temporarily
-update the nic firmware: http://h18023.www1.hp.com/support/files/networking/us/download/23040.html
-if you are using CPQMPK.PSM, try using ACPIDRV.PSM instead inside your startup.ncf file
-if your switches are intelligent, please set them to AUTO and set your NIC driver to AUTO by using the switch SPEED=0 in your autoexec.ncf file
-if your switches are not intelligent, please set your NIC driver to AUTO anyway via the switch SPEED=0 in your autoexec.ncf file
-if using AUTO does not work, set both sides to 100-HALF Duplex
-update all firmware on the server using the latest firmware CD 7.4: http://h18007.www1.hp.com/support/files/server/us/download/23331.html


see the following articles on why disabling hyperthreading is important:

http://support.novell.com/cgi-bin/search/searchtid.cgi?/10091810.htm
http://www.novell.com/coolsolutions/feature/637.html

let us know how it goes!
Patrick Schmidt
Occasional Visitor

Re: DL380 G3 Netware stops communicating

Thank you Ryan for posting a response to my query. I've already done some of the items you suggested and will try the others. I have a couple more questions: are these general troubleshooting options for this server or are they known to solve this problem? What do you base this information on, particurlarly the information about hyperthreading?

Thanks again.
Patrick
Ryan Goff
Valued Contributor

Re: DL380 G3 Netware stops communicating

Disabling hyperthreading has been known to help with many troubles.

Unfortunately though there have been a lot of issues with the older versions of the q57.lan driver as well so if what I suggested does not help at all you may be looking at a bad NIC.

You could also try an Intel PCI NIC to see if the issue goes away as well as a last restort. If the issue goes away with an Intel NIC then most likely you would need a new systemboard.

Only last thing I forgot to mention was cabling, has the cabling been swapped out between the switch and the server?
Ryan Goff
Valued Contributor

Re: DL380 G3 Netware stops communicating

Hi again Patrick,

I wanted to apologize as the SPEED=0 switch will not work on this adapter, that is a setting for the Intel version of our NIC's.

If you want to force the q57.lan driver to use specific settings use these options:

Speed=
This keyword is to force the line speed of the adapter. When this keyword is used, the switch to which the adapter cable is connected to must be forced. If not, the adapter and switch may run at different duplex modes. It is important to have the switch and adapter set properly. The best way to ensure good connectivity is to not set the speed keyword and allow for automatic link setup (auto-negotiation).
Choices are:

AUTO, 10FD,10HD, 100FD, 100HD
Default is Auto. (Note that 1000 FD is only auto-detected at this time.)


Link=
This keyword is only used to allow the adapter to negotiate a specific or forced line speed with a switch that is not forced, but instead setup for auto-negotiation. It is best to allow for auto-negotiation of the card and switch by not setting this keyword or the speed keyword. Only use this keyword if the speed keyword is set to something other than AUTO.
Choices are: AUTO, FORCE
Default is FORCE because the speed keyword is usually used when a switch and the adapter speeds are both forced to a specific value.


Typically you want to make sure that the switch and NIC match for settings ie: auto/auto, 100half/100half, 100full/100full. If you have any settings that are auto/100half or 100half/auto or 100full/auto or auto/100full or 100half/100full etc... you may run into communiation drops or degraded performance.