HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL380 G3 RAID won't rebuild

 
Vince Butler
Advisor

DL380 G3 RAID won't rebuild

I have a ProLiant DL380 G3 that has four 36GB drives configured in a RAID5 array. The server is running NetWare 6.5 SP5. One of the drives failed, so I removed it and inserted a spare. The rebuild started automatically and ran for a few minutes, then stopped rebuilding and changed back into queued mode. Tried rebooting server and also tried swapping with another drive and same thing happened in both cases. I tried putting one of the drives in another server and it rebuilt successfully so the drive is definitely good. I am not seeing any explicit errors anywhere - it just stops rebuilding. Is there some method to force the rebuild? Maybe if I do an offline (OS not booted) rebuild it will succeed?

I haven't updated the firmware since last summer, but I'm leery to try that since I am having this problem. I don't want to hose the array or something.
3 REPLIES
Brian_Murdoch
Honored Contributor

Re: DL380 G3 RAID won't rebuild

Vince,

This can happen when one of the existing members of the raidset has hard read errors. The new disks you are inserting will probably be OK, it's the fact that on reconstructing a new drive, the controller has to write parity and stripe data to it by reading the data on the existing members. Unfortunately this often doesn't show up until one disk fails although I'm sure that an Array Diagnostic Utility (ADU) report will show which disk is the actual cause.

I don't believe Netware has an ADU utility, only ACU (CPQONLIN.NLM) so you would have to boot from a Smartstart CD to run ADU and generate the report file. This report file (REPORT.TXT) can be analysed to uncover what's wrong. Even inserting the original drive won't help here as it would initiate a rebuild and even if it worked for a short time the same problem would occur.

This type of fault very often has to be resolved by a rebuild from scratch deleting and reconfiguring the raidset and restoring data, so get a full backup as soon as possible as you may have to recreate the raidset. As a starting point you need to find the "real" cause of the problem so if possible can you run Smartstart and ADU to generate the report file. If you attach it to a reply it can be checked.

Regards,

Brian
Vince Butler
Advisor

Re: DL380 G3 RAID won't rebuild

I haven't run this report before - can you give me an idea about how long it takes to run? I want to make sure I schedule the correct amount of downtime.
Javier Granados
Occasional Advisor

Re: DL380 G3 RAID won't rebuild

Hello Vince.

Regarding the time that the report takes, well, no more than a minute...

You will need to take in count that the reboot process and boot into the SmartStart CD could take 10 minutes maybe.

So you don't need a long downtime.

And you will need a floppy drive and a blank floppy disk in order to save the report.

Regards,
Javier.