ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL380 G5 and RDP - capture array configuration doesn't work

Robert Flach
Occasional Visitor

DL380 G5 and RDP - capture array configuration doesn't work

Hi

I spent the whole week to find a solution in this forum but without a success.

I try to configure the array of a DL380 G5 Server (with a P400 SAS Controller) with Rapid Deployment.

I got a working script from a teammate in the US.
But this doesn't work here in europe.

-----------------
Action= Configure
Method= Custom

; Controller Specifications
; Controller HP Smart Array P400
Controller= Slot 1
ReadCache= 50
WriteCache= 50
RebuildPriority= Low
ExpandPriority= Low
SurfaceScanDelay= 15

; Array Specifications
Array= A
; Array Drive Type is SAS
; 2I:1:2 (36 GB),2I:1:1 (36 GB)
Drive= 2I:1:2,2I:1:1
OnlineSpare= 1I:1:6

; Logical Drive Specifications
LogicalDrive= 1
RAID= 1
Size= 34695
Sectors= 63
StripeSize= 128
ArrayAccelerator= Enabled

; Array Specifications
Array= B
; Array Drive Type is SAS
; 1I:1:5 (146 GB),2I:1:4 (146 GB),2I:1:3 (146 GB)
Drive= 1I:1:5,2I:1:4,2I:1:3
OnlineSpare= 1I:1:6

; Logical Drive Specifications
LogicalDrive= 2
RAID= 5
Sectors= 32
StripeSize= 64
ArrayAccelerator= Enabled
-------------------------

I found out that RDP got a job to capture the configuration from a server.
I modify the job so it only capture the array configuration.
But the job aborted with a error message:
"boot to windows-automation not possible"

What does this message mean?
How can i fix this?

Perhaps someone can modify the scipt i posted so it works.

Thanks
7 REPLIES
James ~ Happy Dude
Honored Contributor

Re: DL380 G5 and RDP - capture array configuration doesn't work

Robert Flach
Occasional Visitor

Re: DL380 G5 and RDP - capture array configuration doesn't work

Thanks for your reply.

But I forgot to say that we are using Rapid Deployment Version 6.8

This is the Script i am using(default script):
Run Script Capture Array Configuration
set outputfile=%#*"select replace([prod_name],' ',' ') from computer where
computer_id={ID}"%-windows.ini
call %ALTIRIS_SHARE%:\lib\bin32\winpe\acu.cmd -c %outputfile% -internal

The script from the manual you postet uses a different file and folder which does not exist in my version.(\lib\bin16\acr.bat)
I think this is an older one.

How about a firmware update of the array controller?
Could this fix the problems?

Any other suggestions?

please help me, before i am going insane.
James ~ Happy Dude
Honored Contributor

Re: DL380 G5 and RDP - capture array configuration doesn't work

Change the set outputfile=â ¦ entry to set outputfile=capw2k3.ini. This output file will receive the array configuration information.

Then, At the Deployment Console, drag the modified Read ProLiant ML/DL/BL System and Array Configuration and Windows Image {WinPE} job and drop it onto your target server & at the Schedule Computers for Job screen, select Run this job immediately and click OK.

Also,
Verify if this file is created :

C:\Program Files\Altiris\eXpress\Deployment Server\lib\
hwconfig\array\capw2k3.ini (array configuration file)
Robert Flach
Occasional Visitor

Re: DL380 G5 and RDP - capture array configuration doesn't work

I tried it this way but the same error message appears in RDP:
-Booten in die Windows Automatisierung nicht möglich
-boot to windows-automation not possible

Perhaps the script have a problem with the windows login. Could it be?
James ~ Happy Dude
Honored Contributor

Re: DL380 G5 and RDP - capture array configuration doesn't work

Whoaa !
thats crazy !
Could be Robert. I havent seen such case yet.
Perhaps, wait for others to reply.

In the mean time I Will try researching on it ..
Robert Flach
Occasional Visitor

Re: DL380 G5 and RDP - capture array configuration doesn't work

Now i got another DL380 G5 with three 36GB SAS drives.

I tried to configure the Array with the same scripts.

But the "Deploy Array Configuration Script" aborted again with a return code=2822 (and once 2832).

What does these return codes mean?
Is this something like an error code?
Is there any list where i can find these codes?
Robert Flach
Occasional Visitor

Re: DL380 G5 and RDP - capture array configuration doesn't work

Finally i solved the Problem.

I modified several scripts and now i got a working one.
This is only a test-script that creates one Raid 5 with two logical drives:
(sometimes less is more)
-----------------
Action= Configure
Method= Custom

Controller= Slot 1
ClearConfigurationWithDataLoss= YES
SurfaceScanDelay= 15

Array= A
Drive= 2I:1:3,2I:1:2,2I:1:1
OnlineSpare= No

LogicalDrive= 1
RAID= 5
Size= 20000
ArrayAccelerator= Enabled

LogicalDrive= 2
RAID= 5
Size= Max
ArrayAccelerator= Enabled
-------------------------
But now i can simply modify the script for different arrangement of physical drives.

And the "Capture Array Configuration" job is also working fine without any error messages.

Perhaps the server or array controller got a malfunction.

Thanks a lot for your "wasted" time!!!