ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL380 G7 Uncorrectable Machine Check Exception

 
Nicolai Rasmussen
Regular Advisor

DL380 G7 Uncorrectable Machine Check Exception

We have a bunch of new DL380 G7, and so far we've seen this happen on 3 of them:

Uncorrectable Machine Check Exception (Board 0, Processor 1, APIC ID 0x00000001, Bank 0x00000005, Status 0xF2000000?, Address 0x00000000?, Misc 0x00000000?)

Running Windows Server 2008 R2. This error causes the machine to reboot. The server is idling, as it has not yet been put into production. We have the Hyper-V role installed, but no VMs yet.
19 REPLIES 19

Re: DL380 G7 Uncorrectable Machine Check Exception

Hi,


RESOLUTION
Ensure that only one NIC port is enabled for PXE boot.

Since the default System ROM setting has only one port enabled for PXE boot, perform the following if additional ports were enabled:

Reboot the server. During POST, press F9 to enter RBSU.
Select "System Options."
Select "Embedded NICs" and select only one NIC for "Network Boot." Ensure that the other NICs are set to "disabled" (that this does not disable the device; it only removes it from being available to PXE boot).


That will also fix the problem :) Remember to assign points to answers that helped in your problem. So the forum stays alive...
Kind Regards,
Erdogan.
No support by private messages. Please ask the forum!

Accept or Kudo

I am HPE Employee
Highlighted
Nicolai Rasmussen
Regular Advisor

Re: DL380 G7 Uncorrectable Machine Check Exception

I appreciate your suggestion, but I have already read the advisory that you are referring to myself. Perhaps I was a bit vague in my description of the problem, but the PXE boot issue is only an issue IF/WHEN you try to PXE boot, and multiple NICS are enabled for PXE boot. I'm not trying to PXE boot, nor have I changed the default setting (only 1 nic enabled for PXE boot). - I'm simply trying to keep my servers from spontaniously rebooting :)

If others find this (un)helpful, here's the advisory that I'm referring to:

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&taskId=110&prodSeriesId=466340&prodTypeId=12169&objectID=c02251106
Nicolai Rasmussen
Regular Advisor

Re: DL380 G7 Uncorrectable Machine Check Exception

Sorry, wrong link :P

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c02039369〈=en&cc=us&taskId=135&prodSeriesId=3794183&prodTypeId=329290
Jan Soska
Honored Contributor

Re: DL380 G7 Uncorrectable Machine Check Exception

Hello Nicolai - is there any difference between setup of 3 "bad" and other dl380g7's ?

jan
Nicolai Rasmussen
Regular Advisor

Re: DL380 G7 Uncorrectable Machine Check Exception

Hi Jan,

no they are all setup using the same procedures. Same OS and same bios settings.
We don't change the default bios settings, since all virtualization features is enabled per default. All servers have been upgraded to the latest bios version and none of them have any PCI cards installed.
Jan Soska
Honored Contributor

Re: DL380 G7 Uncorrectable Machine Check Exception

Hmm, could you more for testing purposes system drives from 1 bad to 1 good? If good one becomes bad - there is definetelly problem in your system OS config as only drives very changed... If issue stays on bad one, there is hw problem and contact HP?

Jan
Nicolai Rasmussen
Regular Advisor

Re: DL380 G7 Uncorrectable Machine Check Exception

We've replaced the motherboards on the faulty servers and we have not seen the errors since.
Nicolai Rasmussen
Regular Advisor

Re: DL380 G7 Uncorrectable Machine Check Exception

Nicolai Rasmussen
Regular Advisor

Re: DL380 G7 Uncorrectable Machine Check Exception

Firmware 2010.08.16 fix this issue. It was - at we at some point expected - CPU related. The latest microcode from Intel fixed it.

- It appears that this is NOT the finale fix for this issue. We still have servers with UMCE errors after the bios upgrade. Two servers had the motherboard replaced, and it hasn't happened on them since, so I would go with that solution for now...