HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL380 G7 with P410i Getting Horrible Read/Write Speeds (Server 2012)

 
Justin Emlay
Advisor

DL380 G7 with P410i Getting Horrible Read/Write Speeds (Server 2012)

All my HP servers have a P410i Array Controller.  If I put Server 2012 on any of these machines I get horrible read speeds.

 

I can copy a 4GB file to them at normal speeds (120MB/s).  But if I try to copy 1,000 files that total 500MB I only get about 1.2MB/s).

 

Here's an ATTO result which shows something is very wrong:

 

The driver is the most up to date 62.24.2.64 (26 Oct 2012) as is the FW 5.70 (D) (20 Nov 2012).

 

I would appreciate any help!

11 REPLIES
PGTRI
Honored Contributor

Re: DL380 G7 with P410i Getting Horrible Read/Write Speeds (Server 2012)

hi,

 

Please attach an ACU report.

 

Thanks

 

regards,

How to Say Thank You? Just click the KUDOS!
Justin Emlay
Advisor

Re: DL380 G7 with P410i Getting Horrible Read/Write Speeds (Server 2012)

Thank you very much for your reply.  I've attached the the ACU report I generated from yesterday.

PGTRI
Honored Contributor

Re: DL380 G7 with P410i Getting Horrible Read/Write Speeds (Server 2012)

hi,

 

I don't see any errors in the report. 

 

You can update the FW of the hdds.

 

Are you facing the same performance issue in other servers, but with different hard drives or you have the same type of drives in all your servers?

 

Thanks

 

regards

 

How to Say Thank You? Just click the KUDOS!
Justin Emlay
Advisor

Re: DL380 G7 with P410i Getting Horrible Read/Write Speeds (Server 2012)

Some are HP, some are not.

 

Some are SAS, some are not.

 

Some are 3.5", some are 2.5".

 

Some are single drives, Some are RADI5, Some are RAID10.

 

All my P410i machines are affected.  Any time I try to install Server 2012 or upgrade R2 to 2012 they become affected with this horrible transfer rate on small files.

 

I haved two machines that use a P400i and they are running server 2012 fine.

Justin Emlay
Advisor

Re: DL380 G7 with P410i Getting Horrible Read/Write Speeds (Server 2012)

Well, at least I know it's not just me.  A friend who has DL380 g6 and g7 is having the same exact issue. 

 

However, if he uses the default drivers from server 2012 he has less of an issue.  So then my problem is, I'm using HP drivers and having this major issue.

 

Is there any way to find/get/extract the windows drivers and replace my HP drivers?

Ken Krubsack
Trusted Contributor

Re: DL380 G7 with P410i Getting Horrible Read/Write Speeds (Server 2012)

I'm presuming you're using the drivers from the October 2012 HP Service Pack for Proliant?

Justin Emlay
Advisor

Re: DL380 G7 with P410i Getting Horrible Read/Write Speeds (Server 2012)

That is correct (2012.10).  I also used the package before that with the same problem.  Once I saw that the October build claimed it added "Server 2012" support I was excited to get the problem fixed.  Then I was greatly disappointed when the problem persisted.

 

I spent yesterday finding a way to extract the Server 2012 WIM file (had to use an alpha 7-zip build).  I took the drivers from the installer wim and loaded those.  Same exact results.  Once the test hits 512 the read speed goes to pot.

Ken Krubsack
Trusted Contributor

Re: DL380 G7 with P410i Getting Horrible Read/Write Speeds (Server 2012)

The other thing I would be curious about is your mix of drives in the individual arrays.  Are you mixing SAS/non-SAS, HP/non-HP in any given array?  Also, I would look at 3G/6G, spindle speeds (10K/15K), single port/dual port... in the old SCSI world (if I'm not mistaken on this!) a mix of drives would drop down to the lowest common denominator for transfer rate and bus width across all drives in an array - which could murder the speed.

 

The other thing that could be at play is a flake in Win 2012 - or one that still exists from every previous version of windows Server I've worked with.  I haven't messed with 2012 at all, but I know from previous versions of Windows that the WORST thing you could do to the Windows filesystem is throw a scratload of small files at it.  Folders like that would destroy backup performance - and still do, frankly.

Jeffrey D Chard
Frequent Advisor

Re: DL380 G7 with P410i Getting Horrible Read/Write Speeds (Server 2012)

I had a similar problem in copying small files from windows 7 workstation to a sbs2003. The problem was the antivirus Kaspersky. Once I disabled antivirus on the workstation performance improved to normal.
Justin Emlay
Advisor

Re: DL380 G7 with P410i Getting Horrible Read/Write Speeds (Server 2012)

I wish that was it.  No antivirus and it happens from drive to drive on the same machine as well as over the network.

Justin Emlay
Advisor

Re: DL380 G7 with P410i Getting Horrible Read/Write Speeds (Server 2012)

Here's a fresh install using the HP provided driver signed by MS (v7.0.12.0):

 

WindowsDriver.jpg

 

As you can see, not much difference.  The lack of support for such a widely used array board is very disappointing.