ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL380 GEN8 - ILO Errors

 
Advisor

DL380 GEN8 - ILO Errors

Hi all,

I´ve a few DL380p G8, and fans speeding up to 100%, takes me to update all ILO and Bios for last version, all system are ok with two exceptions two DL380p G8 wich serial number is one after other, at same production. The error reports bad ILO initialization, looking corrections the ways are downgrade to 2.61 and cross fingers for a correction at ILO Chip (SD/Nand) or format the ilo, any help to correct it will be welcome.

On diagnostics, we have a Embedded Flash/SD-CARD with Controller Firmware revistion 2.10.00 and Embedded media initialization failed due to media write-verify test failure.

Can anyone help me solve this problem?

Thanks.

Nélio Abreu

 

21 REPLIES 21
Valued Contributor

Re: DL380 GEN8 - ILO Errors

We have a large number of these iLO4 modules in our datacenter.  The 2.70 firmware appears to be more capable than 2.62 or 2.61 when working with SD card format problems.  I have been upgrading our iLO4 modules to 2.70 as the very first step.

Advisor

Re: DL380 GEN8 - ILO Errors

Hi may_bk,

The errors reported are related to ILO need to be formated?

NA

Acclaimed Contributor

Re: DL380 GEN8 - ILO Errors

see

https://support.hpe.com/hpsc/doc/public/display?docId=a00048622en_us

note: pull the power plugs after initiating a format.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Advisor

Re: DL380 GEN8 - ILO Errors

Hi,

Do you have experience in formating the ILO Flash?

Have you done this before?

Did it work?

For what I have understood from the link, I need to place the Administrator password for the ILO in the XML file Force_Format and I have to reload the Inteligent Provisioning!

NA

 

 

Acclaimed Contributor

Re: DL380 GEN8 - ILO Errors

No, with current ILO firmware you just need to click "Format", then pull the plugs, then check ILO log for success.

 

ILO-NAND-Format.jpeg


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Advisor

Re: DL380 GEN8 - ILO Errors

Hi,

This note:

note: pull the power plugs after initiating a format.

I pull the power plugs during the format process, without letting it finish?

 

NA

Acclaimed Contributor

Re: DL380 GEN8 - ILO Errors

The advisory says "A server AC power removal may be required (prior to the NAND format) in order for the NAND format to be successful."

 

Based on my experience if you click "Format", the command is queued, ILO will reboot and format during boot. If you pull the plugs, the command is still queued but not yet performed, so pulling the plugs quickly after selecting "Format" will cold start the ILO, then it formats during boot.

 

You should consider to first pull the plugs, then format, then check for success. If not successful, try the other way.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Advisor

Re: DL380 GEN8 - ILO Errors

What about the message in the screen, about having to install all back?

NA

 

Valued Contributor

Re: DL380 GEN8 - ILO Errors

Yes, the SD card format and/or initialization errors are occasionally mitigated by upgrading to firmware 2.70.  I would do this upgrade as the first step.

If the web interface is malfunctioning so badly that you cannot reach the format/reset screen, there's the nuclear option.  First Install the HP iLO Powershell cmdlets on a system that has connectivity to the iLO.  Then create this file:

 

 

 

<RIBCL VERSION="2.0">
<LOGIN USER_LOGIN="adminname" PASSWORD="password">
<RIB_INFO MODE="write">
<FORCE_FORMAT VALUE="all"/>
</RIB_INFO>
</LOGIN>
</RIBCL>

 

 

 

 

Change the username and password to the appropriate values.  Save it to C:\ as Force_Format.xml.

Then in powershell:

$xml = ([string](get-content "C:\Force_Format.xml"))
$iLOIP = "<ip address>"
$username = "adminname"
$ilopassword = "password"

Invoke-HPiLORIBCLCommand -server $iLOIP -Username $username -Password $ILOpassword -RIBCLCommand $xml -DisableCertificateAuthentication -verbose

Again, replace "adminname" and "password" with the appropriate values.