ProLiant Servers (ML,DL,SL)

DL380 Gen10 M.2 enable

 
martinav
Occasional Contributor

DL380 Gen10 M.2 enable

I have installed an NVMe M.2 drive into drive 13 on the riser card.  I was not finding the device, nor any area in the BIOS that finds the devices for boot.  I could not find anywhere to enable the function.  Are these devices available for boot?  

13 REPLIES 13
tom_ash
Advisor

Re: DL380 Gen10 M.2 enable

Hello martinav,

I suppose you have connected the drive in the M.2 port on the primary riser (877946-001).
The server should be in "UEFI Boot Mode" to enable NVMe boot support.
Access the HPE Smart Storage Administrator and select the S100i controller. The M.2 drive should be visible there.
With the single drive, you can configure RAID 0 on it and make it a boot device.

--------------------------------------
If you feel this was helpful please click the KUDOS! Thumbs below!

I am an HPE employee
martinav
Occasional Contributor

Re: DL380 Gen10 M.2 enable

I verified UEFI boot mode, but I did not find the S100i controller setup.  I could only find the P408i setup.  Can you be more specific where to find the setup uptions for the S100i?

 

Thank you.

Jimmy Vance
Honored Contributor

Re: DL380 Gen10 M.2 enable

If you do not see the S100 identify during POST, you will need to go into the system configuration settings and enable the S100 controller if it has been totally disabled

No support by private messages. Please ask the forum! 
martinav
Occasional Contributor

Re: DL380 Gen10 M.2 enable

@Jimmy Vance ,

 

Thanks for the reply.

 

I have been through the entire BIOS.  I found no reverence to the S100 at all.  Is there an option ROM I need to interrupt during post, prior to BIOS?

Jimmy Vance
Honored Contributor

Re: DL380 Gen10 M.2 enable

Under system Configuration SATA Controller Options

380Gen10SATA.png

No support by private messages. Please ask the forum! 
Mbajelan
New Member

Re: DL380 Gen10 M.2 enable

I can't see any of  nvme m.2 on S100i Drives

WouterH
HPE Pro

Re: DL380 Gen10 M.2 enable

Hello Martinav,

 

What is the spare part number of the riser?

The default riser, 877946-001, only support M.2 SATA drives and not M.2 NVME drives.

 

Kind regards,

Wouter

I am a HPE Employee

Accept or Kudo

monkeybrians
Occasional Visitor

Re: DL380 Gen10 M.2 enable

Is their another replacment riser card that supports M2. nvme

IT-Admin
Visitor

Re: DL380 Gen10 M.2 enable

@Jimmy Vance Currently I am having same problem, after I fllowed your instructions I can see HPE Smart Array S100i Gen10.

However still we can't see the 2 connected M2. NVMe could you please help me if you have any ideas why I still can't see them. FYI our NVMe are Crucial 2TB.

Thank you in advacne very much any help...