ProLiant Servers (ML,DL,SL)

DL380 Gen10 - SPP - TPM Warning

Frequent Advisor

DL380 Gen10 - SPP - TPM Warning


On Gen10 servers in Automatic SPP mode, we get a TPM warning that we haven't come across before.

Is there a switch we can edit in the grub.cfg to bypass the TPM warning?  Screen shot attached.

These are barebone servers with no Operating System, on a bootable SPP ISO (Full, not custom).Screen Shot 2018-07-09 at 12.58.43 PM.png


Re: DL380 Gen10 - SPP - TPM Warning

There are few ways to get around this, I'm assuming you have software TPM and not hardware. 
1.) Setting TPMvisibility to hidden.  This will allow you to use the SPP without user intervention.
Line 1848 and below is a good example

2.) Get a baseline of the packages you need and extract them from the SPP. This lets ilo install them on the next reboot. (off the top of my head so I may be missing a flag but this will get you 90% of the way there)

$session = connect-hpeilo -IP <fqdn> -Username <username> -Password <password> -DisableCertificateAuthentication
Add-HPEiLORepositoryComponent -Connection $session -Location <File> -CompSigLocation <compfile> -Confirm
Invoke-HPEiLORepositoryComponent -Connection $session -Filename <FileName> -TaskName “BIOSUpdate1_40” -UpdatableBy “UEFI” -Expire 0 -Confirm -TPMOverride


Jimmy Vance

Re: DL380 Gen10 - SPP - TPM Warning

I am in discussion with SPP team on how this can be set as a flag or option to skip warning

No support by private messages. Please ask the forum!