ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL380 RAID says drive missing

John Rowan_2
Regular Advisor

DL380 RAID says drive missing

I am not sure what "generation" the DL380 I'm having problems with is.  It has 2 Xeon 2.8Ghz processors which will probably identify the generation for those more knowledgable than me.  The server had 6 x 147.1GB, 10,000 RPM drives in a RAID 5 configuration with an online spare.  Drives 0,1,2,3,4 were the RAID drives and drive 5 the online spare. SCSI was configured as simplex but I changed to duplex Monday thinking it might cause the server to recognize failed drive 2 had been replaced, it didn't.  The online spare had been pulled into service several weeks ago when drive 2 failed.  Parity on the online spare completed it's building and I tried pulling the failed drive, inserting a new 146.8GB 10,000 RPM drive.  When I did that the other drives all went to failed status within a few minutes and Linux crashed.  I pulled drive 2, cycled power, the hardware said drive 2 had failed and should be replaced, shut it off, inserted disk drive, turned on, all drives spun up but before linux started loading drives went to failed status again.  I pulled drive 2, cycled power leaving drive 2 out.  I'd seen something similar on other DL380s I support.  I'd changed the SCSI implementation from simplex to duplex in those situations which solved the failing drive symptom.  I didn't have a SCSI terminator handy at that time.  Monday was when I returned to that server to switch from simplex to duplex.  I installed drive 2, powered the server up, all drives spun up, no failing drive lights, linux booted but drive two was not pulled into array nor was drive 5 returned as online spare.  Downed server, cycled power, went into array configuration (F8), it showed drive 2 missing.   Went into create array, it showed drive two as only available drive to create raid 0 array.  Why is it not seeing drive 2 to reintegrate into RAID 5 array (missing) but seeing it as available to create new drive?  Is it because the other 5 are 147.1GB and this is 146.8GB ??????

1 REPLY
Jimmy Vance
HPE Pro

Re: DL380 RAID says drive missing


John Rowan_2 wrote:
 Why is it not seeing drive 2 to reintegrate into RAID 5 array (missing) but seeing it as available to create new drive?  Is it because the other 5 are 147.1GB and this is 146.8GB ??????

I'd say yes, the issue is the replacement drive is smaller than the other disks in the array




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!