ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL380/RHEL4: how to make hpsmhd listen on multiple interfaces

milprog
Occasional Visitor

DL380/RHEL4: how to make hpsmhd listen on multiple interfaces

Hi all
I successfully installed psp 7.30 on my DL380G4 running RHEL4. My box has no GUI. By default,
netstat -lnp | grep hpsmhd
reports that the web agent is listening on 127.0.0.1:2381 and 127.0.0.1:2301 .
I would like to make it listen on my "real" interface too. How can this be done?

btw,
service hpsmhd configtest
returns the error message
"could not open document config file /opt/hp/hpsmh/conf/hpsmhd.conf".
I can see that there is a file "smhpd.conf" in this directory. Pointing to this file with a symlink "hpsmhd.conf" removes this message, but editing this file does not help to resolve the issue.
Any ideas?
2 REPLIES
Rich Purvis
Honored Contributor

Re: DL380/RHEL4: how to make hpsmhd listen on multiple interfaces

I guess what you mean by your "real interface" is an IP address other than the loopback address? By default the System Management Homepage should bind to all the available IP addresses unless it is specifically configured otherwise. Why it is not doing that I cannot say, but you might try configuring it to bind directly to the IP address you would like it to use and see if that changes the behavior at all.

If you are local to the box and can browse to the 127.0.0.1:2301 - there is a settings tab once you select that there is a box that is labeled System Management Homepage with the option for Security. One of the options in the Security menu is to bind to an IP address or set of IP addresses. You might try that and see if it helps.

Good Luck.
-Rich
Why does my tivo keep recording Nickelodeon?
Mark Carbonaro_1
Occasional Visitor

Re: DL380/RHEL4: how to make hpsmhd listen on multiple interfaces

I've been struggling with this issue all day and I finally came up with a solution. Run the following...

perl /usr/local/hp/hpSMHSetup.pl

It will allow you to specify the interface IP address to listen on, if you don't specify it only listens on 127.0.0.1.