ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL380 - SSD Firmware upgrade - how do i know its worked ?

Robert-Buck
Occasional Advisor

DL380 - SSD Firmware upgrade - how do i know its worked ?

Hi there

I have a DL380 G6 server with two 60GB SSD drives

(Model: ATA MK0060EAVDR)

The latest firmware for this device is labelled up as HPG6 (nothing to do with the server G6). It just so happened that the SSD's we purchased had really old firmware on them (HPG2). I downloaded the G6 firmware for these devices , link below

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=329290&prodSeriesId=3802118&swItem=MTX-0e6de01db3734ce99b33680ca3&prodNameId=4134162&swEnvOID=54&swLang=13&taskId=135&mode=3

created my bootable iso using hpfwtkt and proceeded to perform the upgrade

however, when finished, I boot the OS and run the hpacucli command to get the details and it still reports the device as a HPG2 ... see below

# hpacucli controller slot=0 pd 1I:1:2 show detail


Smart Array P410i in Slot 0 (Embedded)

array B

physicaldrive 1I:1:2
Port: 1I
Box: 1
Bay: 2
Status: OK
Drive Type: Data Drive
Interface Type: Solid State SATA
Size: 60.0 GB
Firmware Revision: 3732HPG2
Serial Number: DCF0S00943SE943A4491
Model: ATA MK0060EAVDR
SATA NCQ Capable: True
SATA NCQ Enabled: True
PHY Count: 1
PHY Transfer Rate: 3.0GBPS

I suspected that this information may be 'burnt in' on to the disks circuit board. Is there an alternative way of me establishing for sure whether this firmware upgrade from HPG2 to HPG6 has actually happened ?

any help would be great

2 REPLIES
TTr
Honored Contributor

Re: DL380 - SSD Firmware upgrade - how do i know its worked ?

What happened during the upgrade process? Do you see the activity that takes place at each step? And are there any messages that tell you the progress and whether the process was successful or not?

Were the FW files specific to SSD drives?
Robert-Buck
Occasional Advisor

Re: DL380 - SSD Firmware upgrade - how do i know its worked ?

Thanks for the reply TTr. I am using a bootable linux firmware upgrade iso create using the hp firmware toolkit


# /opt/HPQfwtk/sbin/hpfwtk mkiso -o /var/tmp/first.iso /var/tmp/CP012538.scexe /var/tmp/CP012108.scexe etc etc

When you flash using this method, you boot into a command line linux, press (F) to perform firmware upgrade. it then returns with a

"successfully applied firmware"

which is all great

however, when the OS boots, i dont seem to have any real visibility that this update has occurred (see hpacucli output below which still says HPG2)