ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL380G3 100FDX not possible

Egonle
Occasional Advisor

DL380G3 100FDX not possible

Hi,

I have quite some DL380G3 machines. Each NIC (broadcom, NC7781) is connected to a dedicated Cisco 6500 (switching module).

When Switch and NIC are configured to 100FDX Windows 2000 displays "network cable unplugged". Using a auto-auto configuration it works.

As I would like to define the configuration as exactly as possible fixing speed/duplex to 100FDX is a must.

Unfortunately the later systems (about october 2003) do not run in a 100FDX configuration.

After I updated the NIC boot prom to 2.33 the first NIC runs in 100FDX configuration but not the second it only works in auto-auto configuration.

SmartStart 6.4 is installed => driver version 6.64.
Checking the configurations of the Cisco boxen didn't show any difference in configuration.

Regards,
EE
7 REPLIES
Glenn N Wuenstel
Valued Contributor

Re: DL380G3 100FDX not possible

I haven't looked at what exactly has changed, but I'm pretty sure that SmartStart 7.00 has updated the NIC drivers. I've gotten quite a few notifications that changes were made, but I've not taken the time to read them. I'd recommend that you upgrade to SS 7.00 and see if it fixes you problem. Yeah I know it is the easy way out to say go to the latest drives -- but no one has every accused me of not being lazy.

Glenn
Egonle
Occasional Advisor

Re: DL380G3 100FDX not possible

Hi,

I updated to latest drivers (7.35) and still there's this problem.

I just read a few other posts and found that someone pointed out that there seems to be a problem with auto-MDIX.
Is this a validated statement?
Is it possible to disable auto-MDIX on the NIC?
Is there a firmware upgrade (current version 2.33)?


Regards,
EE
Sunil Jerath
Honored Contributor

Re: DL380G3 100FDX not possible

Hello Egonle,

The issue with not being able to force with the teaming utility we were able to duplicate in the lab, however was traced down to a bad patch at the frame, once that was replaced our utility forced just fine, but the MS gui was not able to.

What we have come across is an incompatability between the MS gui and ours, where a registry key is written by our util ( DisableAutoNeg ), the key is not known by the MS Gui and therefore with the key present and in its last state, the MS gui does not flip the state of the bit, which causes a problem with the key that MS does change "RequestedMediaType". These 2 conflict and thats why the MS gui breaks the connection. However we were not able to duplicate the break with our teaming utility, only the MS gui. What we did notice is deleting the key "DisableAutoNeg" if the MS gui is used ( and this is not suggested ). However if you use the Teaming utility after that key is deleted and make changes with the teaming utilty then the key will be rewritten to the registry.

Again we are not saying to delete the reg key, I have just documented this so it is known what the cause is.

Resolution/Workaround

At current time there is no supported workaround. A fix is currently being worked on, ETA is NCDE 7.6 which is a March '04 release.

Regards,

Egonle
Occasional Advisor

Re: DL380G3 100FDX not possible

Hi,

btw. we just tried to use a DOS BootDisk and we seem to have similar trouble in getting 100FDX working properly.
Is that driver "messed" up as well?

Regards,
Egonle
Occasional Advisor

Re: DL380G3 100FDX not possible

Dear Sunil Jerath,

according to Cisco Professional they don't know of a problem by their switching engines.

My guess is that the NIC firmware has some trouble. When I use a cross over cable the link comes up quite properly. There seems to be a problem with auto MDI/MDI-X. Isn't there an option to disalbe auto MDI/MDI-X on the NIC?

Regards,

EE
Sunil Jerath
Honored Contributor

Re: DL380G3 100FDX not possible

Hello Egonle,
Whatever options are there those would be in the properties of the NIC. I shall check around and let you know if I find something.

Regards,
Egonle
Occasional Advisor

Re: DL380G3 100FDX not possible

After a few weeks of looking at that problem and getting HP Support to figure it out. I did neither solve the problem nor get any call from HP Support.

Anybody else on that?
Might it be some problem of problems getting a correct voltage on both sides?

Rgds,
EE