ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL380G4,SA6i,SA641,Ultrium448 and reboot

SOLVED
Go to solution
Mann_2
Frequent Advisor

DL380G4,SA6i,SA641,Ultrium448 and reboot

Hello to all,

to the first: sorry for my english!
it's very bad, but i hope you can help me.

i have a problem with an Proliant DL380G4 server and his components:

the Server has 2 SCSI-Controllers, one onboard 6i-controller with 4 HDD's in Raid5 and one 641-controller on pci-slot 2 with an external Ultrium 448 backup-device.

the operating System is Red Hat Enterprise Linux ES release 4 (Nahant)
Kernel 2.6.9-5.ELsmp on an i686

the cciss-driver is 2.6.6-6, firmware of all components are new.

Backupsoftware is yosemite TapeWare Version 7.00 SP7D.

when i try to backup the system with tapeware or with simple tar, the server make a reboot.

i think the problem is that in the system are 2 controller and these works over one cciss-driver?

i find strange that the Ultrium at the boot-time(before loading the operating system) is properly reconized with scsi-id 5 at the second controller.



dmesg say:
-----------------------------------------------
Vendor: HP Model: Ultrium 2-SCSI Rev: S24D
Type: Sequential-Access ANSI SCSI revision: 03
st: Version 20040403, fixed bufsize 32768, s/g segs 256
Attached scsi tape st0 at scsi0, channel 0, id 0, lun 0
st0: try direct i/o: yes (alignment 512 B), max page reachable by HBA 4294967295
cciss0: No device changes detected.
cciss0: No appropriate SCSI device detected, SCSI subsystem not engaged.
cciss1: SCSI subsystem already engaged.
i2c /dev entries driver



Vendor: HP Model: Ultrium 2-SCSI Rev: S24D
Type: Sequential-Access ANSI SCSI revision: 03
Attached scsi tape st0 at scsi0, channel 0, id 0, lun 0
st0: try direct i/o: yes (alignment 512 B), max page reachable by HBA 4294967295
cpqci: module license 'Proprietary' taints kernel.
Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0, type 1

-----------------------------------------------

less /proc/scsi/scsi say:

Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
Vendor: HP Model: Ultrium 2-SCSI Rev: S24D
Type: Sequential-Access ANSI SCSI revision: 03

-----------------------------------------------


but scsi0 Channel: 00 Id: 00 Lun: 00 should be the internal controller?

what's the problem?

thank you for your help and kind regards from germany

roland

Roland
2 REPLIES
Ruslan
Respected Contributor
Solution

Re: DL380G4,SA6i,SA641,Ultrium448 and reboot

Hi Roland!

The problem is in SCSI controller. It possible, but NOT recommended connect ANY tape device to Smart Array Controller. Change or add SCSI HBA for Ultrium like this http://h18004.www1.hp.com/products/servers/proliantstorage/adapters/133mhz-dual/
Mann_2
Frequent Advisor

Re: DL380G4,SA6i,SA641,Ultrium448 and reboot

Hi RusIan,

thanks for the fast reply.

i think this will reslove my problem.

i will buy a new controller in any days:

374654-B21 HP U320 SCSI HBA 1.

i hope it works properly after this change.

best regards

Roland

Roland