ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL380G4 + hprsm-7.3.0 + RHEL 4 + " The hprsm RPM installation failed!"

Ralf Gross_1
Occasional Visitor

DL380G4 + hprsm-7.3.0 + RHEL 4 + " The hprsm RPM installation failed!"

Hi,

I just installed a new DL380G4 server with RHEL 4. Everything seems to work fine, but I have problems to install the HP Lights-Out Drivers and Agents (hprsm-7.3.0-58.rhel4.i386.rpm). I updated the Red Hat Server with all current patches, what means that the Kernel is now 2.6.9-11.ELsmp instead of the default 2.6.9-5.ELsmp.

I have downloaded the 2.6.9 kernel source and installed the kernel rpm. Then I created the symlink /usr/src/linux which points to the kernel source directory.

linux -> usr/src/redhat/BUILD/kernel-2.6.9/linux-2.6.9/

gcc, make...etc. are installed.

If I install the hprsm rpm, I get the following output:

rpm -i hprsm-7.3.0-58.rhel4.i386.rpm

Please read the Licence Agreement for this software at

/opt/compaq/hprsm/hprsm.license

By not removing this package, you are accepting the terms
of the "License for HP Value Added Software".
Building custom cpqci driver
Failed to rebuild for custom kernel.
No insight management devices available
(missing or disabled) on this system.
Please remove the hprsm package at your
earliest convenience (rpm -e hprsm).

==============================================================================
NOTE: New cma.conf entries were added to the top of /opt/compaq/cma.conf
==============================================================================
Starting HP Lights-Out Drivers and Agents (hprsm):

The hprsm RPM installation failed!


Any ideas, what might be wrong?

Ralf
5 REPLIES
Ralf Gross_1
Occasional Visitor

Re: DL380G4 + hprsm-7.3.0 + RHEL 4 + " The hprsm RPM installation failed!"

Hi,

here is some more debug output from the init of the hprsm driver. I ran the command

sh -x /opt/compaq/hprsm/hprsm init verbose

and attached the output to this post.

I hope I'm correct in assuming the hprsm driver should work with the build in ILO of the DL380G4?

Ralf
milprog
Occasional Visitor

Re: DL380G4 + hprsm-7.3.0 + RHEL 4 + " The hprsm RPM installation failed!"

Ralf,
I successfully installed the entire proliant support pack (psp-7.30.rhel4.linux) on my DL380G4 running the RHEL4 clone CentOS4. As part of this install hprsm-7.3.0-58 was also installed. All I had to do is modify the string in "/etc/redhat-release" to avoid the PSP complain about not being 'original RedHat'. I'm running kernel 2.6.9-5.0.3ELsmp on x86_64 (64bit mode).
I'm recalling that I had problems earlier with individual RPM installs vs. installing the complete PSP. Just my 2 cents worth.
HTH
--Marcel
Ralf Gross_1
Occasional Visitor

Re: DL380G4 + hprsm-7.3.0 + RHEL 4 + " The hprsm RPM installation failed!"

Hi,

I installed CentOs 4 a while ago - before we decided to buy RHEL 4. I did the same as you to get the HP agents running, but I can't remember if the hprsm driver installed cleanly.

The only thing I can think of, is the different kernel 2.6.9-11, so that the hprsm driver tries to rebuild, but fails.

I opened a case at HP support 3 days ago, but haven't heard anything from them until now.

I tried to install the hprsm driver by rpm and with the install script of the psp package with the same (negativ) result.

Ralf
Ralf Gross_1
Occasional Visitor

Re: DL380G4 + hprsm-7.3.0 + RHEL 4 + " The hprsm RPM installation failed!"

Hi,

I finaly solved the problem. I installed the kernel source rpm for 2.6.9, but needed the kernel-smp-devel-2.6.9-11.EL.i686.rpm. After installing the dev rpm, the hprsm driver compiled and started fine.

Ralf
Ralf Gross_1
Occasional Visitor

Re: DL380G4 + hprsm-7.3.0 + RHEL 4 + " The hprsm RPM installation failed!"

see above