ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL380G5 - ILO not recognised, possible corrupt firmware

PadraicC
Occasional Visitor

DL380G5 - ILO not recognised, possible corrupt firmware

Hi, I have a DL380 G5 running ESX 3.5. I am running a maintenance update on one of my hosts. I downloaded the HP Firmware Update DVD 9.30, after booting from this DVD and performing an automatic update ( a previous server, same model etc, did it without any issues), I am now in the situation where the server books very slowly, it take approx 10+mins before the proliant logo is displayed on screen. The press F8 for ilo is never displayed (I'm assuming there is a timeout trying to load the ilo drivers),

 

The server can then boot as normal, but without any ILO. I have tried to redo the firmware update, it seems to update all other firmware but does not see/detect the ILO to update. I found the below articles explaining how to recover from a corrupt ilo, but when I try this, it cannot find the reference file "CP014256.scexe" in the swpackages folder as specified after booting: (I have confirmed that this file is on the DVD before booting, is it possible it only displays files for detected hardware?)

 

I am hoping someone has experienced this before and can point me in the right direction. Any assistance is appreciated.

 

http://www.michaelm.info/blog/?p=208

 http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01850906

2 REPLIES
Oscar A. Perez
Honored Contributor

Re: DL380G5 - ILO not recognised, possible corrupt firmware

The below Customer Advisory contains steps to recover a corrupted iLO2 using Firmware DVD 9.30. Good luck

 

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01850906

 

Edit: I just saw you already tried the steps on the advisory.  Did you flip the iLO security switch on the system board before booting up the DVD?

 

From the directory where CP014256.scexe is located, execute:

 

sh CP014256.scexe --direct    (<---  note that there are two dashes before direct)

 

This will flash iLO2 in direct mode. To do so, the iLO securiry switch needs to be in the ON position and HPILO module has to be unloaded prior to execute this command.

 

Also, before booting up the server to firmware DVD, remove the power cord from the server for about 10 seconds to ensure iLO2 processor resets.




__________________________________________________
If you feel this was helpful please click the KUDOS! thumb below!
PadraicC
Occasional Visitor

Re: DL380G5 - ILO not recognised, possible corrupt firmware

Hi,

 

Thank you for your reply. Yes I had tried all you suggestions. Just figured out what was wrong. When I was trying to load the ILO image, the file was not being found or executed, this was due to case sensitivity with Linux. I'm not familiar with Unix OS, so a silly mistake. Once I used the correct case, the firmware installed correctly. I am back online, everything is working as expected.

 

Thank you again for your response.