ProLiant Servers (ML,DL,SL)

DL380P Gen8 restart suddenly after SPP & OS upgrade with logs "ASR Detected by System ROM"

 
Kflihan
Advisor

DL380P Gen8 restart suddenly after SPP & OS upgrade with logs "ASR Detected by System ROM"

Dears, 

We have an old  DL380P Gen8 server was working fine and stable with Redhat 6,5 for long time, 

now after upgrading the server to SPP 2018 and redhat 7.4(3.10.0-693.39.1.el7.x86_64),   The server start suddenly  restarting when the load increased, while it is operating normally at the low load. 

IML logs  "ASR Detected by System ROM" 

OS log messages have no errors, no crash dump,  only next messages was noticed befor restart.

  14 08:46:30 *********  kernel: perf: interrupt took too long (2503 > 2500), lowering kernel.perf_event_max_sample_rate to 79000

  14 08:57:13  *********  kernel: perf: interrupt took too long (3137 > 3128), lowering kernel.perf_event_max_sample_rate to 63000

  14 10:55:09  *********  kernel: perf: interrupt took too long (3923 > 3921), lowering kernel.perf_event_max_sample_rate to 50000

  14 12:29:5  ********  kernel: perf: interrupt took too long (4912 > 4903), lowering kernel.perf_event_max_sample_rate to 40000

  14 14:04:12 *********  kernel: perf: interrupt took too long (6182 > 6140), lowering kernel.perf_event_max_sample_rate to 32000

 any of you encountered such a problem on this server? Any advice would be appreciated.
Thank you in advance

* we can not  upgrade it  to the  latest and newest firmware  because its a bundled software from third party and they dont accept any patches or updates unless upgrade their software bundle too (additional cost ).

 

kflihan
1 REPLY 1
SanjeevGoyal
HPE Pro

Re: DL380P Gen8 restart after SPP & OS upgrade with logs "ASR Detected by System ROM"

Hello,

An ASR event is indicative of the host OS being in a hung state. When the hardware detects the host OS is hung, it will reboot the server. Please check the OS logs and server health logs to see if there were any errors logged


Just disable ASR, in my experience it will only cause problems (especially with LinuX).

ASR disable
Reboot the server.
Press F9 during POST to enter the RBSU.
Select 'Server Availability' and press Enter.
Select 'ASR Status'and press Enter.
Select 'Disabled'and press Enter.
Press Esc to close menu
Press Esc to exit utility.
Press F10 to confirm exit and save changes.
Server will automatically reboot.

 

Also check/update ILO firmware with the latest.

 

Please let me know for further assistance.


I am a HPE Employee

Accept or Kudo