ProLiant Servers (ML,DL,SL)

DL380e Gen8 + B320i Controller, No Hard Drives Found


DL380e Gen8 + B320i Controller, No Hard Drives Found

Hello All,

     I have a DL380e Gen 8 with a B320i Controller that has mysteriously stopped recognizing that hard drives are plugged into it.  I have taken the mini-SAS cables and plugged them into a HP P410 RAID Controller Card that I had laying around and it sees all the hard drives just fine.  So that means that the hard drives, backplane, and the cables are fine.  In looking at the ACU, I noticed that there was no license key present at all, I've been reading that apparently a B320i needs a License Key in order to recognize SAS hard drives.  So, I have a spare 832510-001 hard drive (which is a 1TB 7.2k SATA 2.5" drive) and plugged it into the server, and it still says that it doesn't detect any hard drives.

     So, I ordered two new HP 684896-001 riser Controller Cards to swap with the existing one.  I've now tried both of them in the machine and yet it still doesn't recognize that any hard drives are connected to it.  There are very few actual pictures of the B320i controller on the internet but I did find one on HPE's website:

which is what I purchased.  I find it statistically in the realm of winning the PowerBall that BOTH of these riser cards are bad, so I am reaching out to the community to find out, are all the electronics of the B320i on these riser cards, or is there something on the motherboard that may be damaged?

For the record, I plugged the HP P410 RAID Controller Card into the top slot of the riser board each time, and each time it recognizes all hard drives without issue.  This deepens the mystery for me because it seems impossible that the PCI-E slots would work on each board, but the B320i controller would be damaged in the same way.


Any and all help woulid be appreciated on figuring out what actually needs to be replaced here to make the B320i recognize the hard drives again.  Thank you for your time.