ProLiant Servers (ML,DL,SL)
Showing results for 
Search instead for 
Did you mean: 

DL380p Gen8 Unexpected Shutdown

Occasional Visitor

Re: DL380p Gen8 Unexpected Shutdown

I had same problem as Threonine with ProLiant DL360e Gen8. I used HPE USB Key Utility 2.1 to make bootable USB key of SPP 2016.10.0 iso. I  booted with the key and used Automatic mode to update the firmawres. After updating the SPP stuck to "Please wait, analyzing system...." screen. I waited about 45 mins and booted the server forcefully. During booting I could see that iLO was updated.

Now ran the SPP in Interactive mode. All the other things were updated expect Power management. I updated that and rebooted again to SPP in Interactive mode. Now SPP showed that everything is up to date.

Originally I started to update the firmware because the ESXi was complaining of loosing connect to /bootbank

Fritsch James
Frequent Advisor

Re: DL380p Gen8 Unexpected Shutdown

I recommend to always use interactive firmware update. Automatic update does behave strange sometimes. The "Please wait, analyzing system" indeed lasts for quite a long time in soime configurations - just be patient. It shouldn't take hours though.


Re: DL380p Gen8 Unexpected Shutdown

Hold CTRL+ALT+SysRq,

tap R, E, I, S, U, ......  (watch the options on screen)

once B is pressed, the system will immediately reBoot.


Raising Elephants Is So Utterly Boring.



Re: DL380p Gen8 Unexpected Shutdown

Sorry to dredge up an old thread, but I had the same problem with an old used dl380p gen8. It had iLO 4 v1.4 and Intelligent Provisioning v1.3.  I used an SPP 2017.04.0 iso on a HP usb utility created usb drive to update all the firmware in one go, including ilo 4 to v2.55. I used automatic update, and it seemed to install everything, but on reboot, it hung on the same analyzing system message that everyone else was having. I tried force rebooting to the SPP, and the automatic update hung on analyzing again. I couldn't access ilo 4 through the web interface.

I updated Intelligent Provisioning, and could access ilo 4 through that, but no amount of resetting or setting changes seemed to help. I could also access iLO 4 configurator through hitting F8 during boot, but no matter what network settings I used, I couldn't access ilo 4 through the web interface. Pulling power cords and rebooting also didn't help.

I then hit reset to factory default in the ilo 4 configurator (F8 during boot), noted the ipv6 address that showed up during boot, and tried logging in with that, which worked. I then booted into the SPP usb interactive mode, went to firmware, and it showed everything was updated. 

I think the key here is to somehow force a reset of ilo 4/the embedded flash, and resetting to factory defaults through the configurator (F8 at boot) seemed to do the trick. There's probably a script way of doing it, too.

I could then use the web interface to change the ipv4 settings, do a reset of ilo 4, and then use the web interface with the static ipv4 address to log in again.