ProLiant Servers (ML,DL,SL)

DL385 G10 Plus servers rejecting NVMe drives on ports other than 1A

 
kondor
Occasional Advisor

DL385 G10 Plus servers rejecting NVMe drives on ports other than 1A

I have tested it on DL385 Gen10 Plus and Plus v2 servers (total of 4) with the same outcome. To both of them I have applied HPE 2021.10 SPP through IloAmp. On top of that I have applied newest BIOS 2.52. Here's the situation: both servers stoped recognizing NVMe drives unless these drives are connected to port 1A on the I/O board (motherboard). I have tested it on two separate 8SFF NVMe cages (U.2) to exclude the cage problem and with multiple different NVMe drives (P5800X Optane and 905P Optane).  After a boot I can see the message in the Ilo Integrated Management Log like "NVMe Storage - Drive at NVMe Drive Port 2A Box 2 Bay 4 status changed to Removed". The drives are being recognized as Inserted and right after that they are being Removed. I have tested hundreds of different configurations to exclude the potential failure points. The funny part is it worked about a year ago before I upgraded some firmware. I tested multiple drives on a new server and they were all showing up, but because I only needed two of them to work I didn't notice at what time and after which upgrade it stopped working. Now when I try to add more NVMe drives I noticed the problem. I tried downgrading with older SPP versions but with no success. RBSU factory settings didn't help. Two CPU configurations are the same. Only port 1A recognizes drives. I tested all the ports on the I/O board. All the ports on the cage and cables are confirmed good when they are connected to port 1A. Like I said i spent already good 60 hours trying to solve they mystery and I got to the point when I need to ask for your help. This seems to be problem that could potentially affect many users, why I don't see other people inquiring about such issues?

Did anyone else experience similar issues and knows the solution?

1 REPLY 1
TVVJ
HPE Pro

Re: DL385 G10 Plus servers rejecting NVMe drives on ports other than 1A

Hello,

If you are using HPE option parts and the issue still persists, then it sounds like more investigation is needed. You may contact HPE Support as well.

Regards,

I work for HPE
Views expressed herein are my personal opinion and are not the views of HPE

Accept or Kudo