ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL385 G2 RHEL 4 update 4 and ACU

SOLVED
Go to solution
R. Verkerk
Frequent Advisor

DL385 G2 RHEL 4 update 4 and ACU

Hello,

I am trying to install cpqacu on my RHEL4 update 4 DL385 G2. I get an error message. What am I missing? My error message is:

# rpm -i cpqacuxe-8.0-14.noarch.rpm
error: Failed dependencies:
libstdc++-libc6.2-2.so.3 is needed by cpqacuxe-8.0-14.i386

If I look it has a version installed:
# rpm -qa | grep libstdc
compat-libstdc++-33-3.2.3-47.3
libstdc++-3.4.6-3
libstdc++-3.4.6-3

Has anybody seen this before?

gr,

Robert Verkerk.

5 REPLIES
Jim Malcolm
Occasional Advisor
Solution

Re: DL385 G2 RHEL 4 update 4 and ACU

You didn't say whether your RHEL4 is i386 or x86_64. It's most likely that cpqacu wants one and the library is the other.

Try: rpm -q --queryformat "%{NAME}-%{VERSION}-%{RELEASE}.%{EPOCH}.%{ARCH}\n" -a | grep libstdc. That may give you the insight you need.

Jim Malcolm
R. Verkerk
Frequent Advisor

Re: DL385 G2 RHEL 4 update 4 and ACU

Hello,

This is my output:

henkel-rnd# uname -a
Linux henkel-rnd 2.6.9-42.ELsmp #1 SMP Wed Jul 12 23:32:02 EDT 2006 x86_64 x86_64 x86_64 GNU/Linux
henkel-rnd# cat /etc/redhat-release
Red Hat Enterprise Linux AS release 4 (Nahant Update 4)
henkel-rnd# rpm -q --queryformat "%{NAME}-%{VERSION}-%{RELEASE}.%{EPOCH}.%{ARCH}\n" -a | grep libstdc
compat-libstdc++-33-3.2.3-47.3.(none).x86_64
libstdc++-3.4.6-3.(none).x86_64
libstdc++-3.4.6-3.(none).i386
henkel-rnd#


gr,

Robert Verkerk
Jim Malcolm
Occasional Advisor

Re: DL385 G2 RHEL 4 update 4 and ACU

libstdc++-libc6.2-2.so.3 is in the glibc rpm. See if you have glibc and the architecture.
R. Verkerk
Frequent Advisor

Re: DL385 G2 RHEL 4 update 4 and ACU

Hello,

It was fixed as follows:
- install compat-libstdc++ x86_64
- install compat-libstdc++ i386

than I could install cpqacuxe-8.0-14.noarch.rpm

There was one extra error. cpqacuxe would not start. It complained about library's.
It was fixed by modifying: /usr/sbin/cpqacuxe. In here we modified LD_ASSUME_KERNEL=blabla to the version I have.

gr,

Robert Verkerk
R. Verkerk
Frequent Advisor

Re: DL385 G2 RHEL 4 update 4 and ACU

Fixed as seen in above reply.