ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL385G5P Servers hanging with Hyper-V live migration

 
Ascendo
Occasional Advisor

DL385G5P Servers hanging with Hyper-V live migration

Hi everyone

I'm hoping someone here can help, as I have not managed to come right with HP support (although spares are on their way) or Microsoft support.

We have 6 Windows 2008 R2 + Hyper-V cluster deployments (on a variety of hardware - DL365, DL385, Dl585, DL360). They all run fine, except the DL385G5P servers, which ALL exhibit the same behaviour:

About 50% of the time we perform a live migration (moving a running VM from one physical host to another), the host server freezes up completely. It is so frozen that not even an ILO NMI crash dump does anything.

Now this behaviour is being experienced across two different clusters of 385G5P servers, and these servers were purchased about 7 months apart, so I don't think it's a bad batch of boards or something.

Microsoft support has checked the cluster config and it's all correct. HP is sending a new motherboard to test with tomorrow, but in the mean time I'd like to find out if anyone is using Hyper-V R2 on Dl385G5P servers successfully? I suspect there could be an incompatibility issue which no one else has picked up yet.

We have done the following:

- swapped out memory
- installed with and without smartstart
- upgraded all firmware (firmware cd 8.7)
- updated windows
- updated all drivers to latest version
- tried with and without teaming

I have run out of options. It looks like the 385's were a poor choice to run Hyper-V.

Rgrds

Ascendo

7 REPLIES
marcus1234
Honored Contributor

Re: DL385G5P Servers hanging with Hyper-V live migration

Ascendo last time i saw this issue it was related to cpu..
cast an eye here

check out the intel link too from site below..

http://ts2community.com/blogs/rwagg/archive/2009/02/06/hyper-v-live-migration-details.aspx

good luck
Ascendo
Occasional Advisor

Re: DL385G5P Servers hanging with Hyper-V live migration

Thanks for the link, but all 7 servers have the same CPUs (dual Opteron 2384), and all exhibit the same problem.

In addition, having different CPU types will cause live migration of the VM to fail, and not the entire host (and therefore all the VMs on it).
Danny McDermott
Occasional Visitor

Re: DL385G5P Servers hanging with Hyper-V live migration

Hi,

We get exactly the same symptoms as mentioned.

We also find that the Hyper-V nodes also freez or lock up under heavy load. I can try and login via iLO or RDP, but it gets to the Welcome message after typing in username / password and just sticks there. It's really annoying. All the latest patches are installed to the OS, and the latest firmware and drivers have been applied.

This also manifests itself on DL385 G2 systems, but Live Migrate does not cause the system to crash.

Does anyone else have this issue too ?
Ascendo
Occasional Advisor

Re: DL385G5P Servers hanging with Hyper-V live migration

This is an interesting development.

We still have open cases with both HP and MS. I have in fact shipped two of my servers to MS to enable them to investigate the problem.

What CPUs are you running? What storage are you using? We have only been able to replicate the problem with more than 1 VCPU - could you perhaps try with only 1 VCPU assigned to the VM to see if you experience the crash?

I would also appreciate it if you could log a case with HP and reference support case # 4610661781. If they know this is not an isolated case, we may get more eyes looking at the problem.

Re: DL385G5P Servers hanging with Hyper-V live migration

Hi Ascendo,

Check below link for advisory for DL385 G5Pserver, hope it will resolve are issue,

Advisory: Windows Server 2008 - HP Integrated Lights-Out (iLO) High Performance Mouse May Not Respond When Running In a Microsoft Hyper-V Virtual Machine
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&taskId=110&prodSeriesId=3454575&prodTypeId=15351&prodSeriesId=3454575&objectID=c01722344

Advisory: Windows Server 2008 R2 - Blue Screen Is Displayed After Initial Reboot When Hyper-V Installed on Windows Server 2008 R2
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01905084〈=en&cc=us&taskId=101&prodSeriesId=3454575&prodTypeId=15351

ProLiant Server Hyper-V Support Matrix
http://h71028.www7.hp.com/enterprise/us/en/servers/ws-server-2008-archive.html


This is how we thank each other in the forum

http://forums11.itrc.hp.com/service/forums/helptips.do?#33

Regards.
Kind Regards,
Erdogan.
I am HPE Employee

If this helps you with your issue, please click the thumb to register a Kudo.
If it resolves the issue, please consider marking it as an Accepted Solution.
The comments in this post are my own and do not represent an official reply from the company. No warranty or guarantees of any kind are expressed in my reply.
Nick Hills_1
Occasional Visitor

Re: DL385G5P Servers hanging with Hyper-V live migration

Hi Ascendo,

We are in the same boat as your post above.

We have 9 DL385g5p servers in two clusters running Hyper-V, and we frequently get crashes on the source host when we perform live migrations.

This afternoon we had another failure, and a google threw up you post with the exact same issue we are seeing.

It would appear that this occurs for us also when live migrating a vm with > 1 virtual processors.

Did you ever find a resolution for this, as there seems to be very little on this issue published elsewhere.

I'd be greatful if you could let me know if you have a resolution, and if so... what was it?

many thanks,
Nick
Nick Hills_1
Occasional Visitor

Re: DL385G5P Servers hanging with Hyper-V live migration

Just as an update on this issue...

There is an aknowledged fault withing the AMD family 10h processoros which causes this problem when migrating VMs with more than one virtual processor.

Microsoft have published a KB article and hotfix here : http://support.microsoft.com/kb/981618

I can confirm (for us, at least) this resolves the issue