ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL580 G2, NC7170 and RIS

 
Adrian Johnson_1
Occasional Contributor

DL580 G2, NC7170 and RIS

We have a W2K SP4 RIS server, which we have been successfully using for sometime to build both our W2K SP4 and W2K3 server build variants. These are all CD-ROM based (i.e. RISETUP) RIS images, which we had managed to keep updated with support for any new hardware HP had cared to release. However, recently we've hit problems with trying to build in support for HP's NC7170 Gigabit NIC card.

The RIS server in question has had the hotfix detailed in Microsoft’s KB823658 article applied, we’ve followed the usual M$ process for building in support for OEM NICS and the NC7170 drivers also reside in the relevant directories, as specified in the OemPnpDriversPath of the answer files. I suspect that the issue relates to both W2K and W2K3 natively containing driver files bearing the same name that do not actually carrying support for the NC7170 (HP introduced this later), but am running out of ideas on how to resolve this issue. The symptoms are:

With our W2K images (using the drivers contained in cp005149.exe), we get a "The file N1000nt5.sys is corrupted" error raised during the textmode set up, whenever we place the NC7170 drivers (i.e. .sys, .inf and .cat) in the I386 directory. I tried various copies and revisions of the NC7170 drivers and even tried doctoring the native driver.cab and drvindex.inf, to remove all reference to the N1000NT5.SYS, but all to no avail. Removing these drivers from I386 results in the, "The Operating System Image You Selected Does Not Contain the Necessary Drivers for Your Network Adapter" error being raised, which is to be expected.

With our W2K3 images (using the drivers contained in cp005151.exe), the install stops during the GUI mode setup prompting for the drivers from the c:\windows\driver cache, despite the drivers being in the directories referenced in the OemPnpDriversPath of the answer file. I’ve managed to get around this issue by including the drivers in the reminst\Setup\English\Images\\$OEM$\$1\WINDOWS\Driver Cache directory, but this is a bit of a kludge and I’d be much happier if we could actually resolve the root cause instead.

I’d be grateful to hear from anyone who has any ideas on how to resolve this one?

Thanks,

Adrian.