ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL580 G2 no network

Robin Wang_1
Occasional Contributor

DL580 G2 no network

I've got this DL580 G2 with 4x2.5 GHz XEON. From what I can see, there is no NIC port on PCI slot 2 as described in the user's manual. I assume it was removed for some reason by someone. Anyway, I added a NC7770 into Slot 2, but Windows 2003 cannot connect to the network. My IP address from this card is 169.x.x.x which is a private one assigned by Windows when no network is available.

The interesting thing is that when the machine boots up, I can see information about a Broadcom NetXTreme NIC installed. I am not sure if this is about the NC7770 or the embedded NIC.

So, any ideas how to fix this?

Many thanks in advance.
3 REPLIES
Matti_Kurkela
Honored Contributor

Re: DL580 G2 no network

By looking at the Maintenance and Service Guide of DL580 G2, it seems this server does not have any embedded NIC: that's why it comes with a NIC in slot 2 as standard.

So it would seem that the NC7770 is producing the messages about Broadcom NetXTreme.

Windows 2003 should certainly be capable of indicating "no link" if that was the case, so I'll assume the physical connection is probably OK. I'd recommend verifying that, though.

Is the network port (at the other end of the cable) configured correctly?

Does this network segment even *have* a DHCP server (or relay), or should you assign the server a static IP address manually?

MK
MK
Robin Wang_1
Occasional Contributor

Re: DL580 G2 no network

Thanks, Matti,

I do have a network configured. The cable connected to this DL580 is coming from a switch. I have verified that the same cable is connected to my main network - if I connect it to a NIC port on a laptop, connection is okay (the NIC in the laptop successfully obtained an IP of 10.x.x.x which indicates it is connected to my network.). The problem is if the same cable is connected to this NC7770 in the DL580, Windows 2003 in this DL580 box canot obtain a valid IP address.

It looks like my NC7770 does not see the DHCP server which is certainly in the network as indicated in the above laptop testing scenario.

Assigning a static IP to NC7770 doe not work wither.
Rancher
Honored Contributor

Re: DL580 G2 no network

You might go into the BIOS and make sure that NIC and slot are not disabled.
Also you might check your NIC properties and make sure the speed is set correctly.