ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL580 G7 Fan Speeds too high

Magic94
Occasional Contributor

DL580 G7 Fan Speeds too high

So I bought an old DL580 G7 for home use, but now i'm not very happy with it because the fans are always at 100%. 

About my config. When I bought it, there was one Intel Xeon X7560 in it with 96GB RAM. Nothing more. At this time the CPU Temp in idle was around 40°C. 

So I added a GTX1080 and the Fans got faster. I know it's related to the PCIe Devices / their Power consumption. But the fans were still at a acceptable speed. 

So I added a PCIe SATA SSD Card (with no external power input) and the fans got faster again. It was around 60% in Idle and 70-75% at full workload. 

So I threw out the X7560 and added two E7-2870 (same as E7-4870, but only supports 2 CPUs simultaneously, and its cheaper) and the fans - which surprise - are now at 100%. Always. 

The CPU is getting freezed at 34°C and my GPU too. My neighbours asked why I always keep on the vacuum cleaner and .... We cant talk in the room where the Server is located. 

I know that servers are built to keep cold and dont give a nice handshake about volume, but I think this isn't purposeful. Also the fans eat a lot of power... I saw a discussion about a DL580 G7 where the CPUs are getting "hot" and the fans still chill. (https://community.hpe.com/t5/ProLiant-Servers-ML-DL-SL/HP-ProLiant-DL580-G7-iOL-3-temperature-threshold-of-cpu/m-p/6969521)

Is there any trick to tell him everything is fine an it's no problem to lower the fanspeed? I configured everything in BIOS and iLO to lower the fan speed but nothing changes at all.

2 REPLIES
Rafi786
HPE Pro

Re: DL580 G7 Fan Speeds too high

Good Day,

Is the Optimal Cooling set in BIOS.

Perform the following steps to manually set the Thermal Configuration to "Optimal Cooling" in the ROM-Based Setup Utility (RBSU):

Press [F9] to enter RBSU settings when prompted during boot.
Navigate to: Advanced Options -> Thermal Configurations.
Select: Optimal Cooling.
Save settings.
Exit RBSU.

 

Mohd Rafiuddin
I work for HPE. The comments in this post are my own and do not represent an official reply from the company. No warranty or guarantees of any kind are expressed in my reply.
8064r7
Occasional Visitor

Re: DL580 G7 Fan Speeds too high

The reason none of the fan issues have any traction isn't because the enterprise market doesn't care, I promise we do.  HPE simply doesn't care about these problems regardless, doubly since we are discussing secondhand which means they don't make a drop of money.  Even the information about their bios they gave you was wrong.

At some point one of the RBSU updates corrupted the advanced cooling algorithm and completely deleted optimal cooling's underlying parameters for the G7's.  Setting to optimal cooling promises you 90% fan speed in the middle of winter, even with direct AC cooling the box ambient. 

Your best bet until you can set a custom rhaebus is to select increased cooling and manage your ambients, that is what I've had the best luck with.