ProLiant Servers (ML,DL,SL)

DL580 G8 different fan speeds across fans

 
tony9
Occasional Visitor

DL580 G8 different fan speeds across fans

Hi we have 3 dl580 G8's

one machine runs fairly quiet under full load with fans speeds:

Fan Block 1 | 36.46 percent | ok
Fan Block 2 | 36.46 percent | ok
Fan Block 3 | 36.46 percent | ok
Fan Block 4 | 23.91 percent | ok

the other two have very uneven fan speeds :

Fan Block 1 | 11.76 percent | ok
Fan Block 2 | 11.76 percent | ok
Fan Block 3 | 62.72 percent | ok
Fan Block 4 | 62.72 percent | ok

This causes the servers to run very loudly.
I have tried all the usual BIOS, ILO updates / swapping fans. hardware is identical except for more RAM in the noisy servers.

The fan issue seems to occur only once the OS (ubuntu server 20.04LTS) has booted. however ubuntu should have no control over the fan speeds.

 

Could somewone share any insights as to what may casue the server to have such drasticaly uneven fan speeds?
Regards Tony

 

4 REPLIES 4
StorageMike
HPE Pro

Re: DL580 G8 different fan speeds across fans

Hi
Once the server passes POST the iLO gets it's heat info from the OS. This is why a server runs it's fans at full speed when there is no OS installed.
Unfortunately there is no OS support for Ubuntu on the DL580 G8 so this is more then likely an driver issue.

I work for HPE

Accept or Kudo

tony9
Occasional Visitor

Re: DL580 G8 different fan speeds across fans

Ok thanks for the info. I was under the impression that if no drivers where available, the BIOS would default to its inbuilt fan profiles. It seems strange that the behaviour is so varied across almost identical hardware.

Could you provide any clues as to the API/interface iLO uses to query the OS for temperatures?

Seeing as it does'nt appear during the OS install process, perhaps there is a library in linux I can disable, to default back to BIOS fan profiles?

 

tony9
Occasional Visitor

Re: DL580 G8 different fan speeds across fans

Just blew high pressure air over the SPI card for some time and the fans span down to normal levels.

The noisy fans are on the same side of the server as the spi card.

Below is the temp logs after leaving it running a bit after the air blast.

"34-HD Controller | 72 degrees C | ok" seems hot but having similar readings in the other server without issue.

 

UID Light | 0x00 | ok
Sys. Health LED | no reading | ns
01-Inlet Ambient | 29 degrees C | ok
02-CPU 1 | 55 degrees C | ok
03-CPU 2 | 57 degrees C | ok
04-CPU 3 | 56 degrees C | ok
05-CPU 4 | 59 degrees C | ok
06-P1 DIMM 1-24 | 49 degrees C | ok
07-P2 DIMM 25-48 | 44 degrees C | ok
08-P3 DIMM 49-72 | 45 degrees C | ok
09-P4 DIMM 73-96 | disabled | ns
10-P1 Mem Buff | 57 degrees C | ok
11-P2 Mem Buff | 55 degrees C | ok
12-P3 Mem Buff | 59 degrees C | ok
13-P4 Mem Buff | disabled | ns
14-HD Max | 35 degrees C | ok
15-Chipset | 58 degrees C | ok
16-P/S 1 | 43 degrees C | ok
17-P/S 2 | 43 degrees C | ok
18-P/S 3 | 43 degrees C | ok
19-P/S 4 | 42 degrees C | ok
20-P/S Zone | 42 degrees C | ok
21-VR P1 | 70 degrees C | ok
22-VR P2 | 73 degrees C | ok
23-VR P3 | 74 degrees C | ok
24-VR P4 | 75 degrees C | ok
25-VR P1 Zone | 46 degrees C | ok
26-VR P2 Zone | 56 degrees C | ok
27-VR P3 Zone | 52 degrees C | ok
28-VR P4 Zone | 56 degrees C | ok
29-VR P1 Mem | disabled | ns
30-VR P2 Mem | disabled | ns
31-VR P3 Mem | disabled | ns
32-VR P4 Mem | disabled | ns
33-SuperCAP Max | 32 degrees C | ok
34-HD Controller | 72 degrees C | ok
35-PCI 1 | disabled | ns
36-PCI 2 | disabled | ns
37-PCI 3 | disabled | ns
38-PCI 4 | disabled | ns
39-PCI 5 | disabled | ns
40-PCI 6 | disabled | ns
41-PCI 7 | disabled | ns
42-PCI 8 | disabled | ns
43-PCI 9 | disabled | ns
44-PCI 1 Zone | 45 degrees C | ok
45-PCI 2 Zone | 46 degrees C | ok
46-PCI 3 Zone | 45 degrees C | ok
47-PCI 4 Zone | 43 degrees C | ok
48-PCI 5 Zone | 42 degrees C | ok
49-PCI 6 Zone | 41 degrees C | ok
50-PCI 7 Zone | 41 degrees C | ok
51-PCI 8 Zone | 41 degrees C | ok
52-PCI 9 Zone | 42 degrees C | ok
53-LOM Card | disabled | ns
54-I/O Zone | 42 degrees C | ok
55-SPI Board | 46 degrees C | ok
Fan Block 1 | 38.02 percent | ok
Fan Block 2 | 38.02 percent | ok
Fan Block 3 | 58.41 percent | ok
Fan Block 4 | 58.41 percent | ok
Power Supply 1 | 255 Watts | ok
Power Supply 2 | 270 Watts | ok
Power Supply 3 | 295 Watts | ok
Power Supply 4 | 0 Watts | ok
Power Meter | 893 Watts | ok
Power Supplies | 0x00 | ok
Fans | 0x00 | ok
Memory | 0x00 | ok
C1 P1I Bay 1 | 0x01 | ok
C1 P1I Bay 2 | 0x01 | ok
C1 P1I Bay 4 | 0x01 | ok
C1 P1I Bay 5 | 0x01 | ok

SanjeevGoyal
HPE Pro

Re: DL580 G8 different fan speeds across fans

Hello,

 

I would suggest you try to install any other supported OS for isolate the issue.

 

Follow the below documents for your reference .

 

https://support.hpe.com/hpesc/public/docDisplay?docId=c04148787&docLocale=en_US

 

https://h20195.www2.hpe.com/v2/getdocument.aspx?docname=c04200246#

 

https://techlibrary.hpe.com/us/en/enterprise/servers/supportmatrix/exceptions/ubuntu_exceptions.aspx

 

If you feel this was helpful please click the KUDOS! thumb below!   

Regards,

 

 

 


I am a HPE Employee

Accept or Kudo