ProLiant Servers (ML,DL,SL)

DL580 Gen9 Express Bay Enablement Kit Question

 
dl580user
Senior Member

DL580 Gen9 Express Bay Enablement Kit Question

Hi All

I purchased the switch card and the express bay backplane separately so I don't have the cables connecting the two.   Then  I used a Gen8 wide mini-sas cable connecting the two,    I went head and try to run the firmware upgrade tool from redhat./spp.  In both cases the update tool recognized the backplan but didn't obtain the firmware version and then tried to update the back plane firmware.   The process failed with error code 42.   When I plug in nvme drives,   the leds simply flashed and the drives didn't get recognized.

The question is did I use the correct cable?   I contacted tech support about the part number for the cables they couldn't find any.   Does anyone have this setup and could you look at the cable and read the part/spare number on it?

Thanks for any help!

7 REPLIES 7
StorageMike
HPE Pro

Re: DL580 Gen9 Express Bay Enablement Kit Question

HI

Have a look at page 30 in the below, hopefuilly it's the info you need

https://h20195.www2.hpe.com/v2/getpdf.aspx/c04601208.pdf

I work for HPE

Accept or Kudo

dl580user
Senior Member

Re: DL580 Gen9 Express Bay Enablement Kit Question

Thanks for the pointer!

I did use the cable spcified on that page:  748916-B21 or (P/N 748942-001).  The reason I suspect it's not the right cable for NVME even thought it physically fit is because: 1) The card recognized the expander but did not read out any fw version number. and update failed.  2) For other server types,  the g9 nvme cables have "scsi-e" labels on them.   One example is a right angled cable 822780-001 for DL380.   Unfortuanely it doesn't fit dl580 g9 since I need straight to straight cables.

Thank you for the reply!

dl580user
Senior Member

Re: DL580 Gen9 Express Bay Enablement Kit Question

Another thing is that when I try to update firmware I get a ILO log message:

Hardware I2C access (0x22 0x80) blocked by host software for 1200 seconds

Does anyone know what this means?

DANDKS
HPE Pro

Re: DL580 Gen9 Express Bay Enablement Kit Question

What is the firmware that you are attempting to upgrade?

Provide the part numbers for switch card and the express bay backplane.

On which Bay are you installing the NVMe Drive?

Where are you checking if the drive is recognized or not? name the application.

If possible, share a photograph of complete view of the cabling done internally in the server.

Thank you


I am an HPE employee
Accept or Kudo
dl580user
Senior Member

Re: DL580 Gen9 Express Bay Enablement Kit Question

Hi

Thanks for the reply!   Here are the parts I am using to try to get nvme backplane working: 

1) switch card:  DG#708724-001,  SP#824019-001.   Firmare updated to 1.78 successfully.

2) expander:   SP#802276-001  REV. 0A      Firmware version unknown.   SUM tries to update to 2.00 unsuccessfully I will get to the error later.

3)  Cable:  I connected just one to port 6&7.    P/N: 748942-001.   connection picture attached.   On the adatper I connected to the port labeled one which is closest to back.

4) I used intel P3700 400G HPE P/N 764891-001 as test disk.   When I plug in,  the leds lit up from left to right and then no led.   I am running rhel 8.2 and no kernel log indicating a drive is inserted.    No change in ILO device inventory (the switch card is listed there).    When I run gparted no drive entry corresponding to the intel drive appears.

5)  When I run the firmware update for the switch card.  The switch card update was succuessfull but the back plane update errors.   I attached the screen shot below too.   Similiar error happens when I do update booted from SPP disk.

Thanks for any help!bplaneupdate.png

 

IMG_20201023_125012.jpg

dl580user
Senior Member

Re: DL580 Gen9 Express Bay Enablement Kit Question

Here is the screen shot showing the hp log generated by the flashing program.   Can someone with i2c programing experience decipher what's the problem here?

Screenshot from 2020-10-25 01-02-36.png

DANDKS
HPE Pro

Re: DL580 Gen9 Express Bay Enablement Kit Question

Thank you for providing the part number information. All the parts are looking good & compatible with the server hardware. However, when we check the firmware file that you are attempting to upgrade, rather downgrade is not compatible with RHEL 8 (8.6). The Express Bay enablement Switch card is already at 2.00 version, you are downgrading the version to 1.78 as per the screen shot that you have shared. We do not have a firmware for the switch card which is compatible with RHEL8. As per the below link, you can see the supported OS versions.

https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_977a33d8eb4c4df4a8cfd62365#tab-history

We would also request you to verify if the Intel NVMe Drives are compatible with the switch card/Backplane

Below link provides you the details of the part numbers included with the kit

https://partsurfer.hpe.com/Search.aspx?type=PROD&SearchText=788359-B21

Please review all the above information & write back for any further queries

Thank you


I am an HPE employee
Accept or Kudo