ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL580 Windows2003 fails during scripted build

Jeremy Pack_1
Occasional Contributor

DL580 Windows2003 fails during scripted build

I'm automating server builds using the SSSTK, SmartStart6.4 and Windows2003.

The build I have works on a DL360G3 and DL380G3 but it fails on a DL580 G2. Basically WINNT (/U:unattend.txt /S:) copies the Windows2003 files on to the C drive on the SmartArray5i+ and then when the server reboots to the C drive it hangs.

I downloaded CP003718 and integrated the new CPQCISSE*.* files into the $OEM$ structure but there is one line in the new txtset.oem that is different. The line includes a dll in [files.SCSI.B060]

Including the new drivers and txtsetup.oem gets the server to boot but Windows2003 install then fails with "Illegal or missing file types specified in section files.scsi.b060. Microsoft KB275334 hints this is the dll line, so I removed it and are now back to the server not rebooting from the C drive during the unattended install.

Any ideas anyone?
3 REPLIES
Neal Bowman
Respected Contributor

Re: DL580 Windows2003 fails during scripted build

At what point in the boot process does the sequence hang? Check your C drive for system files so it can boot (confirm format process), and make sure that the fdisk routine marked the partition as active. Which version of SSSTK are you using? Check you ini files to make sure the array detected is the correct one.
Jeremy Pack_1
Occasional Contributor

Re: DL580 Windows2003 fails during scripted build

>>Check you ini files to make sure the array detected is the correct one.
Which ini file do I need to check?
I'm doing a Winnt /U: etc etc I dont get much choice of a ini file that I can see.

Thanks so far

Others:
>>At what point in the boot process does the sequence hang?
The very beginning. System boots goes though diagnostics talks to ILO, SmartArrary5 controller etc etc then at the point it would boot from the CD the screen goes blank and it hangs.

>>Check your C drive for system files so it can boot (confirm format process), and make sure that the fdisk routine marked the partition as active.
The partition is active. I've formatted it FAT32 and FAT16 at sizes of 2Mb/4Mb and 10Mb (all these work on the DL380s)
I've checked for system files and it all looks normal.

>>Which version of SSSTK are you using?
This is hard to confirm as there does not appear to by any version numbers once you have unpacked the kit but The samples folder includes a W2K3 folder which includes a txtsetup.oem which starts "installs of Windows .Net only"
Neal Bowman
Respected Contributor

Re: DL580 Windows2003 fails during scripted build

The latest SSSTK is 2.2, available for download from the HP drivers and support area of the website. It has a copy of ini files for detecting the hardware model and returning a code that the batch file reads. It also compares the array controllers BIOS and returns a variable for that product as well.

Are you getting a "Starting MS-DOS" or "Starting Windows 9x" banner after POST is complete? Can you try to do FDISK /MBR to lay down the master boot record on the hard disk?