ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL585 G1 hangs during memory test

Coinneach
Occasional Advisor

DL585 G1 hangs during memory test

I have a DL585 G1 that hangs during memory diags. The hang always happens during the "Total memory - address test" phase, and the hang point varies directly with the amount of memory installed. For example, at the moment the system has two CPU/RAM boards, each containing 4 1GB DIMMs for a total of 8GB (all identical part numbers), and the diags hang at 60%. If I install two additional boards with another 8GB, diags hang at 30%. If I bring the system down to 4GB, diags hang at 99%. Overall progress hangs at 12% regardless of installed memory.

You'd think this would point to a motherboard issue, but I installed a new board, and it does the same thing. I've replaced the motherboard, all four CPU modules, and all of the RAM, so I essentially have a new system; the only remaining common denominators are the backplane and chassis, and I can't see any possible way for these components to affect memory addressing.

There are two 72GB 15K U320 hard drives installed, but no OS. System is running SmartStart 8.1, and firmware version 8.2.

The internal error light is on, but none of the top panel LEDS are light and all of the internal LEDs are green.

Ideas?
8 REPLIES
KarloChacon
Honored Contributor

Re: DL585 G1 hangs during memory test

Coinneach
Occasional Advisor

Re: DL585 G1 hangs during memory test

Hello Karlo,

I don't have this version in-house, but I'll dl and burn it at home tonight. Thanks.
Steve Goble
Advisor

Re: DL585 G1 hangs during memory test

I am having a similar issue. If I let it sit long enough the server will restart. I have tried ver 8.00, ver 8.10 and now I am trying ver 8.15.

At least I get to 13%.. nah na nah.
Steve Goble
Steve Goble
Advisor

Re: DL585 G1 hangs during memory test

SS 8.15 receives the same result. I have brought the machine to minimum config and no change. Updated all to FW 8.30. The server boots fine but the diags will not complete... Customer wants the box back so that'll be it for me on this until they complain again...
Steve Goble
Larry Mendenhall
Occasional Visitor

Re: DL585 G1 hangs during memory test

I'm new to the forum. I noticed that the last entry on this issue was Feb.2. Has there been anything found on this? I have this exact issue at a customer site and they are thinking they have a hardware issue. I don't want to go down this rathole of parts swapping if this is a known issue. Has anyone else escalated this issue?
Steve Goble
Advisor

Re: DL585 G1 hangs during memory test

Make sure that this advisory does not apply: http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01554945&dimid=1046218472&dicid=alr_sep08&jumpid=em_alerts/us/sep08/all/xbu/emailsubid/mrm/mcc/loc/rbu_category_AdvisoryProLiant/alerts

I would try the text mode anyway and see what result you get...

"RESOLUTION
As a workaround, while booting the SmartStart Release 8.10 or the Firmware Maintenance CD Version 8.20, perform the following to prevent the CD unresponsiveness:

From the first graphical screen, press the ESC key.
Choose to enter text mode.
At the prompt, type "sos mem=4G" and press the ENTER key. "

For me I had 32GB of memory. The server reported no H/W errors and the customer needed the system back into production. I was not able to troubleshoot further and the system has been running fine with no errors. The memory test however still would not complete...
Steve Goble
Larry Mendenhall
Occasional Visitor

Re: DL585 G1 hangs during memory test

I have tried this memory diagnostic with 2 and 4 gb in memory/proc in slot 2 only. And I've tried it with Smartstart 7.9 as well. So the advisory does not apply. But it sounds like the diagnostics don't work anyway. Has the product division addressed this?
Steve Goble
Advisor

Re: DL585 G1 hangs during memory test

Not by me.

FYI: The product went EOL on Wednesday, January 31, 2007.

Also, I successfully ran the diagnostics on a DL380 G4 to make sure that the test and my CD / USB sticks actually worked.
Steve Goble