cancel
Showing results for 
Search instead for 
Did you mean: 

Disable LLDP

 
SOLVED
Go to solution
vdeli
Occasional Visitor

Disable LLDP

I have a large number of DL Prolient servers installed in our testing lab and am having issues trying to disable LLDP. Packets are sent every 30 seconds and disrupt certain testing. 

I've tried using hbacmd in hopes of disabling LLDP but it seems that utility is geared more towards fiber channel cards than regular network cards. 

Has anyone been able to disable LLDP packets on a Hewlett-Packard Company NC552SFP 2-port 10Gb Server Adapter (Emulex Corporation OneConnect 10Gb NIC (be3) (rev 01))?

Thanks in advance for any replies.

2 REPLIES 2
AmRa
HPE Pro

Re: Disable LLDP

There is nothing in the BIOS of the card about LLDP, however you can enable/disable LLDP from OS level using lldptool by executing below command.

# lldptool set-lldp –i adminStatus=disabled

For more information please refer HP ProLiant Networking Software Release Notes

https://support.hpe.com/hpsc/doc/public/display?docId=c03923333

Also refer lldptool(8) - Linux man page for details about lldptool

https://linux.die.net/man/8/lldptool

I am an HPE Employee

Accept or Kudo
vdeli
Occasional Visitor
Solution

Re: Disable LLDP

I actually discovered a fix for this issue. In my case, I am running CentOS 6/7 servers. The hbacmd utility worked on changing the settings in the NC552SFP NIC, however, it had to be the utility that shipped with elxocm-rhel6-rhel7-11.1.183.24-1.gz 

Any newer version would not interact with the card, using the same commands.

Working commands are where 00-00-00-00-00-00 is the MAC of the port:

/usr/sbin/ocmanager/hbacmd GetDCBParams 00-00-00-00-00-00

/usr/sbin/ocmanager/hbacmd SetDCBParam 00-00-00-00-00-00 dcbxstate 0
/usr/sbin/ocmanager/hbacmd SetDCBParam 00-00-00-00-00-00 txstate 0
/usr/sbin/ocmanager/hbacmd SetDCBParam 00-00-00-00-00-00 rxstate 0

This will disable LLDP on one port. Run the same command on the second port of the card if necessary