HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Disable Processor on DL380 G5

 
Robert Heim
Occasional Visitor

Disable Processor on DL380 G5

We are looking to run some performance tests against our DL380 G5 dual quad-core system (running Windows Server 2k3 x64 Std) and would like to disable one of the processors (i.e. 4 cores).

Is this possible with this configuration?
5 REPLIES
Terence Tsao
Frequent Advisor

Re: Disable Processor on DL380 G5

sorry, u can't disable CPU in BIOS setting.
Only remove CPU to meet your require.
Regards.
KarloChacon
Honored Contributor

Re: Disable Processor on DL380 G5

hi

check this:

/numproc=number
This switch sets the number of processors that Windows will run at startup. With this switch, you can force a multiprocessor system to use only the quantity of processors (number) that you specify. This switch can help you troubleshoot performance problems and defective CPUs.

****
/NUMPROC=
Specifies the number of CPUs that can be used on a multiprocessor system. Example: /NUMPROC=2 on a four-way system will prevent Windows from using two of the four processors.


check also this link:

http://www.windowsitpro.com/Article/ArticleID/20110/20110.html

regards
Didn't your momma teach you to say thanks!
Robert Heim
Occasional Visitor

Re: Disable Processor on DL380 G5

Thanks for the information.

We'll try the boot.ini switch to see if that works. :)
KarloChacon
Honored Contributor

Re: Disable Processor on DL380 G5

hi

ok test the boot.ini and let us know


regards
Didn't your momma teach you to say thanks!
KarloChacon
Honored Contributor

Re: Disable Processor on DL380 G5

well I did it and it work

I had 2 Quad Core Processors ML350 G5
8 Procs in Task Manager

boot.ini
/numproc=1

Now I see 1 Proc in Task Manager so it works for test environments

regards
Didn't your momma teach you to say thanks!