ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

E200 array controller perfomance issue

 
RobInMtl
Occasional Advisor

E200 array controller perfomance issue


Hello all, first post here so be gentle.... :)

I have read quite a few post regarding the E200 array in a few DL machines. SO i guess i am not the only one with issues.... But i was never really able to find a solution or if there is one?

I have a DL180 G5 running windows 2008. I have the E200 not sure if its 64 or 128, i have 4 7200 SATA disks 2 configured as RAID 1 and the other 2 the same, they are 250 gig disk bought from HP(of course). I have not noticed this crappy performance since i tried to move files on C to E drive. I get no more than 4 MBs/s if i am really lucky 5MB/s. The files are a mix mash of text and binary large and small. File system is standard NTFS default allocation unit size.

I am trying to get my firmware version, but the ACU application is pretty flaking, it works when it wants to....

I did turn on caching , but have not rebooted yet, does this make a difference?

The ACU is
HP Array Configuration Utility
Version 8.25.5.0 (windows32)
1/27/2009

ANy ideas...

Thanks
Rob
Montreal, Canada

14 REPLIES
KarloChacon
Honored Contributor

Re: E200 array controller perfomance issue

well ACU version really not matters here
you need to be sure ig your controller has the latest firmware 1.8 and latest driver 6.14.0.32

I see you enabled write caching where? at windows level or using ACU? since ACU has that option which is much better that the windows one

use the ADU - array diagnostic tool to get the firmware version
Didn't your momma teach you to say thanks!
RobInMtl
Occasional Advisor

Re: E200 array controller perfomance issue

Ya , well I installed the ADU, it does not work, as the ACU, i simply get a page not found....

Its a little frustrating that the most basic little things seem to always be a difficult task when it comes to a HP box.

I will try a reboot as its early enough that i can do it now. I will get back to you....


Thanks..
RobInMtl
Occasional Advisor

Re: E200 array controller perfomance issue

SO i ran the ADU by cli... SO i gues i am behind in versions?

Driver is version 6.14.0.64

So next thing i should go to version 1.80?

If so, anything special i should know, will i loose my current array setup of my 2 mirrors?

Thanks..

Smart Array E200 in slot 0 : Identify Controller
Configured Logical Drives 2 (0x02)
Configuration Signature 0xa0085312
RAM Firmware Revision 1.78
ROM Firmware Revision 1.78
Hardware Revision 0x00
Boot Block Revision 1.78
Drive Present Map 0x00000000
External Drive Map 0x00000000
Board ID 0x3212103c
Swapped Cable Flags 0x00
Non Disk Map 0x00000000
Bad Host RAM Addr 0x00
CPU Revision 0x00
PDPI Revision 0x00
EPIC Revision 0x00
WCXC Revision 0x00
Marketing Revision A
Controller Flags Controller Flag
RobInMtl
Occasional Advisor

Re: E200 array controller perfomance issue

Ok, so i upgraded to 1.80, i have to wait till after 5pm to reboot, so i will post after that...

RobInMtl
Occasional Advisor

Re: E200 array controller perfomance issue


Ok, so i rebooted and now have a running firmware of 1.80

No difference... i tried for fun to make sure that write cache was enabled in windows 2008, by checking in device manager and right clicking properties on each array and checking the policy tab, the check box was not checked, i checked , but the check is not saved... it keeps coming unchecked. I read that its because windows does not see any battery backup for the controller, but there is battery backup on the controller and the status shows good... i still cannot get past 6 MB/s its horrible...

ANy more suggestions

Rob Morin
Montreal, Canada

juan quesada
Respected Contributor

Re: E200 array controller perfomance issue

how are you measuring performance? can i get counter numbers to help you figure out why is so slow?

regards,
RobInMtl
Occasional Advisor

Re: E200 array controller perfomance issue


I opened a ticket with HP, they want me to reboot into a diagnostic mode to make sure all hardware is working ok, i suspect it is... so i will do that and then call them back tomorrow as it is a production server.
However i measure by no real scientific means i copy a folder form the C drive to the Newly created E drive, and i get less than 5 MB/s.

What would be a better way to test... use the windows performance app, or is there anything you can recommend?

Thanks..

Rob Morin
Montreal, Canada
juan quesada
Respected Contributor

Re: E200 array controller perfomance issue

Suggested Counter Thresholds for a Server to check disk perfomance.

Disk - PhysicalDisk\% Disk Time
Disk - PhysicalDisk\ Current Disk Queue Length
Processor- %Processor Time
Network Interface Connection - Bytes Total/sec

please gather the information so we can start with the basics.
RobInMtl
Occasional Advisor

Re: E200 array controller perfomance issue


How do i show you the results?

you want graph or just s number report?

juan quesada
Respected Contributor

Re: E200 array controller perfomance issue

for simplicity, just numbers
RobInMtl
Occasional Advisor

Re: E200 array controller perfomance issue


Disk Time jumps between 60.00 & 118.00
Disk Queue Length jumps is either 0.00 or 1.000
Processor Time is between 30.00 & 40.00

Network , well its between local disks, not sure why that matters...

??
juan quesada
Respected Contributor

Re: E200 array controller perfomance issue

Disk - PhysicalDisk\% Disk Time above 90 is consider a bottleneck
Disk - PhysicalDisk\ Current Disk Queue Length of 2 or above is consider a bottleneck

if Processor- %Processor Time and Network Interface Connection - Bytes Total/sec and Disk - PhysicalDisk\% Disk Time If all three of these counters have high values, the hard disk is not causing a bottleneck. However, if %Disk Time is high and the other two counters are low, the disk might be the bottleneck.
RobInMtl
Occasional Advisor

Re: E200 array controller perfomance issue


Ok thanks for the help, i will look in to that.

Rob..

Re: E200 array controller perfomance issue

You're using E200, which configuration?
can you tell me about E200 RAM?
RAID level
and having a BBWC or not?

please remember that a failed BBWC will force your controller to operate in safe conditions and disable all write chaches for fast disk writes.

check for your E200 RAM config, RAID level and state of BBWC.

check your POST messages for warnings.
If no one works, Diag your controller Insight Diagnostics.

Good luck