ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

DamianN
Occasional Contributor

ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

Hi

 

I installed on a PL380 G7 the ESXi Offline Bundle (v1.4-16 from 19.2.13). After reboot I see now the Storage based Hardware status.

Unfortunately the "Storage" is shown as "Warning" at the entry "HP Smart Array P410i Controller : Embedded : HPSA1".

I cannot find anything thats wrong with this hardware, all System Logs are fine.

Any suggestions

thanks for you help

damian

21 REPLIES
Suman_1978
HPE Pro

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

Hi,

 

I am just guessing that there could be some compatibility issues between the ESXi Offline Bundle version and P410i firmware version or the battery is just charging or discharging process.

 

Also see this link from VMware and check the 23rd post onwards:

http://communities.vmware.com/message/1761592

 



Thank You!
__________________________________________
Was the post useful? Click on the white KUDOS! Star.

For product specific Guided Troubleshooting visit; http://www.hp.com/support/hpgt
Want to know How to use HP Guided Troubleshooting?  Visit the below link.
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c03283214

d3vnul
Frequent Advisor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

Unfortunately i cannot remember exactly where I've read about exact same problem and the conclusion was that the issue is related to latest hpsa driver from hp which is part of the v1.4-16 offline bundle. I may suggest that you could try to uninstall the current offline bundle and try installing the previous version one.

Hope my post wont cause any confusion as i cannot remember where exactly I've read all this.

NSK
Occasional Advisor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

I've got the same problem on various bits of hardware. Reverting to the previous bundle gets rid of the warning.

 

Other changes (hpsa driver, firmware etc) make no difference. Its all to do with the bundle.

 

Have logged a call, but not really getting anywhere yet.

kkpro
Regular Advisor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

Hi. The same issue found on brand new installation using ESXi 5.1 HP custom image on DL360 Gen8.

zacha
Occasional Visitor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

Same problem here. Set up two servers with integrated P410i controller with ESXI 5.1 HP Image (newest version) and getting the same error HPSA1 warning with no indication of what could be wrong. Servers don't have a bbu, we only have a small raid 1 for the esxi installation- the rest of the storage is non-local. If I query the controller with hpacucli no errors or warnings are shown. Both disks are okay and the LD too. I assume this to be a bug of the newest CIM provider. Can anyone confirm?

Jantharan
Occasional Visitor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

Hi,

 

I had the same issue on DL580 g7 with 1.4-16 version of offline bundle. Resolved by installing 

 

# esxcli software vib install -d /tmp/hp-HPUtil-esxi5.0-bundle-1.3-6.zip

 

VIBs Installed: Hewlett-Packard_bootbank_hpacucli_9.20-9.0

VIBs Removed: Hewlett-Packard_bootbank_hpacucli_9.40-12.0

 

so the current running version is Hewlett-Packard_bootbank_hpacucli_9.20-9.0

 

Hope this will help...

Mike O.
Regular Advisor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

I'm getting the same thing with our BL465c G7 and a new 460 gen8 when using the latest HP image for 5.1 (5.32.23).  It shows a "warning" on HPSA1, but no indicatations as to what.  The battery and disks are OK.

 

Reinstalling the previous 5.1 iso (5.32.5) from last October and the warning isn't there.  Unfortunately we need the newer Emulex drivers, so it looks like I'll use the old ISO, and then update the network drivers separately.

Mike Celone
Frequent Advisor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

Getting the same exact issue on 3 BL460c G6s with the P410i controller.  All 3 of them show the same issue but disks and batteries are fine.  I am using the latest HP ESXi 5.1 image.  Just noticed it this week when we upgraded.

 

 

Mike
zacha
Occasional Visitor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

okay... so having read the latest replies we tried the following:

 

installing hp offline bundle version 1.3.5-3 and hp offline bundle utils 1.3.6 though esxcli. but this did not help... some vibs where skipped... remember we used the latest hp esxi installation bundle to set up these servers.

 

i then manually removed the smx and ams package through the esxli and installed the offline bundle 1.3.5.-3 which installed the older versions of ams ans smx provider. finally rebooted and... the warning is gone.

 

I suspect the smx-provider vib to be the root cause of this problem. I will try to only swap this single package on another server still sitting there showing warning.

 

...

 

another update... tried it on a second host.

 

uninstalled the hp-smx-provider vib and re installed the old version. the warning is gone.

Bernard Burette
Occasional Visitor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

Hi,

 

Had the same problem, looks like it is linked to buggy HP software, no hardware problem here.

 

I solved it by installing the previous SMX and AMS from HP (not the ones that are packaged with the ESXi 5.1 custom image for ProLiant), here are the steps :

- download HP ESXi Offline Bundle for VMware ESXi 5.x version 1.3.5 (the buggy version is 1.4) ;

- the link for me was : http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=fi&prodTypeId=15351&prodSeriesId=4091412&swItem=MTX-0f7de8802be4423db38c8cb200&prodNameId=4091432&swEnvOID=4115&swLang=8&taskId=135&mode=4&idx=1

- copy the ZIP to a datastore that can be accessed by the ESXi server showing the problem ;

- activate SSH on that ESXi server and log in directly (alternatively you can activate ESXi shell from the console then Alt-F1 and log in directly to the console) ;

- remove the buggy SMX package ;

- the command is : esxcli software vib remove -n hp-smx-provider

- the output of the removal should look like :

  Removal Result
   Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
   Reboot Required: true
   VIBs Installed:
   VIBs Removed: Hewlett-Packard_bootbank_hp-smx-provider_500.03.02.00.23-434156
   VIBs Skipped:

- now install the good version from the ZIP ;

- the command is : esxcli software vib install -d /<<full-path>>/hp-esxi5.0uX-bundle-1.3.5-3.zip

- you have to use the full path to the ZIP, a relative path (like ./hp-esxi5.0uX-bundle-1.3.5-3.zip does not work) ;

- since the ZIP is on a datastore the full path will probably look like /vmfs/volumes/<<datastore-name>>/...

- the output of the installation should look like :

  Installation Result
   Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
   Reboot Required: true
   VIBs Installed: Hewlett-Packard_bootbank_hp-ams_500.9.2.0-11.434156, Hewlett-Packard_bootbank_hp-smx-provider_500.03.01.10.2-434156
   VIBs Removed: Hewlett-Packard_bootbank_hp-ams_500.9.3.0-13.434156
   VIBs Skipped: Hewlett-Packard_bootbank_char-hpcru_5.0.3.09-1OEM.500.0.0.434156, Hewlett-Packard_bootbank_char-hpilo_500.9.0.0.9-1OEM.500.0.0.434156

- you can see that the AMS part was removed and an older version was installed as well ;

- now you have to *reboot* the ESXi server (just stopping and restarting the agents is not enough) ;

- after the reboot in the vSphere client select you host server and go "hardware status" you can confirm the warning is gone and you can browse through software to see which version of SMX and AMS parts are present.

 

This solved my issue, hope it helps you folks.

 

Regards.

 

Mike O.
Regular Advisor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

Other than the HPSA warning in VMWare's hardware status, is there any issue with leaving the SMX/AMS on the version bundled with the latest 5.1 image?

 

I'd like to take advantage of the other upgraded drivers in the newer image, but instead of going through the upgrade to the latest 5.1 image, then manually downgrading a couple of modules on every blade, could I just leave the "buggy" SMX/AMS versions on there and live with the warning until HP releases a fix?

 

I'm just wondering if leaving it there will cause any other any issues, or hide any real warning with the disks or battery.

MercuryGate
Occasional Visitor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

We had the same issue with the hardware status tab consistently showing a warning (reporting a value of 2) for the raid controller.

 

We had HP run their HP Smart Start program on the raid controller and they determined that there were no issues with the raid controller.  We decided to try to use a previous version of the HP Offline Bundle instead of the latest and greatest:

 

latest version from HP:  hp-esxi5.0uX-bundle-1.4-16.zip

previous version:  hp-esxi5.0uX-bundle-1.3.5-3.zip

 

 

When using the older version the issue no longer appears (hp-esxi5.0uX-bundle-1.3.5-3.zip).  So it appears that this is an issue with the latest offline bundle

oaksboard
Occasional Visitor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

Same issue here on a series of DL580 g7 and DL580 g6 servers we recently upgraded to the latest bundle.

 

Would be nice to know from HP if there are any other issues, besides the warning.

My biggest concern at the moment is that a real warning could remain unnoticed.

 

One of the servers has an additional problem: after a few days uptime the hardware monitor switches to "unknown" state.

theweave
Occasional Visitor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

So I have this same thing......I can cleary read the fix but am more interested in the answer, which up to now, seems to have been avoided. 

 

What is the harm in just leaving this alone until HP puts out an update.  Backdating these to clear a GUI icon is not worth the effort where I sit???

 

Also, when is HP going to ackowledge this and give an ETA on a real FIX, not a workaround?

 

-weave

Stan Gobien
Occasional Advisor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

Same problem here on a DL380p Gen8.

 

Also see the topic at vmware communities:

http://communities.vmware.com/message/2222964#2222964

 

I'm waiting for a newer vib that fixes this bug.

jo_strasser
Occasional Visitor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

Hi,

 

same here based on ESXi 5.1-latest and ESXi 5.0-latest (BL465c G7 and BL680c G5)

 

HP: we need a very quick fix ft that pls...

 

Johannes

ragmon
Occasional Visitor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

I'm told that the latest HP Offline Bundle fixes the issues with the hardware status warning vibsdepot.hp.com/hpq/apr2013/

didwenger
Occasional Advisor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

On a DL380p G8 with ESXi 5.0 U2, I have installed the latest HP bundle from April 2013 (hp-esxi5.0uX-bundle-1.4.5-3.zip)  and the error is gone. It's also confirmed in this post: http://www.jonmunday.net/2013/04/16/fix-hp-esxi-5-x-management-bundles/ 

gsedam
Occasional Visitor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

Perfect - Thank you for the detailed explanation.  Works perfect....

Kopp3
Advisor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

Hi @ all.

 

I've run into the same issue after a firmware upgrade to HP_SPP_2014.02 on ML350 Gen8 server (HP customized ESXi 5.1 b1312873). The problem is solved after installing of hp-esxi5.0uX-bundle-1.6-20.zip via VUM.

 

Regards,

Cop

b1lLM_billm
Visitor

Re: ESXi 5.0 Hardware Status shown as Warning - but no all Disks and SA Battery are fine

I am sure this conversation is dead in th ewater but I just ran through the update process and I still have the array and battery warning.  both are functioning properly.

Are there any other steps I can try to clear the warnings?

Thanks,

-Bill

using hpdl380 G6s in DEV environment