ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Embedded SATA RAID on ML110

 
William K
Occasional Advisor

Embedded SATA RAID on ML110

Looking for some help on getting this working on an ML110.

I've tried using both the drivers on the System CD as well as the downloads from hp.com but neither appears to be working. When I run Insight Manager the device is identified as "SATA Controller - Intel SATA RAID Controller".

I tried the installation (GUI) Adaptec utility and that did not install it correctly, either.

When I installed Win2K3 and pressed F6 it did recognize the fact that a controller was present (using one of the Adaptec drivers), however, it did not prompt me for additional configuration during setup. I'm assuming this is not the controller that is installed.

Any help would be appreciated.... am I using the wrong driver? If so, which should I use and where can I find it?
12 REPLIES
raadek
Honored Contributor

Re: Embedded SATA RAID on ML110

William,

Please have a look at my answers in the following thread:
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1021686

As there is the same Intel E7230 chipset in both the ML310G3 & ML110G3 all information is relevant to your case.

Rgds.
Don't panic! [THGTTG]
William K
Occasional Advisor

Re: Embedded SATA RAID on ML110

Thanks for the link, Raadek...

I downloaded the Intel based driver which was recognized during installation. However, I was not prompted to setup a RAID array during the 2K3 installation. Shouldn't that have occured?

Or, is there something in the BIOS that I need to configure?
RufusG
Frequent Advisor

Re: Embedded SATA RAID on ML110

I could not find a suitable RAID system on my ProLiant ML110G2, so I installed a Promise RAID controller board.

Cost about $70

The latest Promise low-cost RAID Host Bus Adaptor is FastTrak2300, which is SATA-2.

I installed 2 additional 160GB disks in RAID-1 configuration, so I have 160GB of more reliable disk storage. Latest disks are SATA-2, which is faster.

I installed the Operating System on the original 80GB SATA disk, so I can reformat this disk and rebuild the OS without disturbing my data.

I have 1 working copy of my data on my workstation.

I have a utility that makes a mirror copy of all this data onto the RAID drive on my ML110G2, so I have a reliable disk-based back-up and archive system.

By a careful approach to storing my data over the years I have pictures and files going back to 1984.

I hope that this description helps you.

Regards
chongkan
Trusted Contributor

Re: Embedded SATA RAID on ML110

Hi, William

When you're booting the server, do you see any "Press F8 to..." before or after the controller initialization?

Read carefully all POST, there should be either ORCA or the PCI controller ROM Configuration Utility otion to setup the array.

Can you tell me what key options are prompted with during POST?

William K
Occasional Advisor

Re: Embedded SATA RAID on ML110

Thanks for the assistance so far. Here's where I'm at:

I was able to get the SATA RAID identified using the Intel based drivers as suggested. I was able to use CTRL-A to access the BIOS utility and setup the array.

When I attempt to install 2K3, however, the setup routine 'hangs' at the point of 'Setup is Starting Windows'. This is after hitting F6 during setup to identify the SCSI (atcually SATA) RAID controller.

Now that the controller is being recognized should I not be using the F6 option during setup? Will 2K3 recognize the hardware from the utility loaded in (I assume) the BIOS?

Thanks again for the assistance...
raadek
Honored Contributor

Re: Embedded SATA RAID on ML110

Here you go mate - you should be fine with this manual:
ftp://aiedownload.intel.com/df-support/9725/ENG/readme.txt
Don't panic! [THGTTG]
William K
Occasional Advisor

Re: Embedded SATA RAID on ML110

Still having issues here. First of all when I download any of the Matrix software packages it will not allow me to install stating "this software is not supported on this chipset"

It almost appears as if this was working and then stopped working for some reason. I noticed that I had a 'mirror' of c:\ on my second drive, however, it just appears to have stopped as no changes to c:\ are being written to the mirror.

If I enable the RAID within the BIOS the server will not boot . If I disable the system boots but there is no RAID functionality.

In the BIOS, if I set SATA Controller to 'Enhanced' and SATA RAID 'Enabled' I get a message of "Cannot recognize Disk on Port 2 & 3 if SATA RAID enabled".

Another plea for assistance... I know this has got to be something small that I'm just not handling correctly but it is getting a little frustrating now.
raadek
Honored Contributor

Re: Embedded SATA RAID on ML110

OK, not many hints left.

Maybe it is worth to try this:
http://intel.com/support/chipsets/inf/sb/CS-009270.htm
?
Don't panic! [THGTTG]
William K
Occasional Advisor

Re: Embedded SATA RAID on ML110

Ok, I'm going to try a fresh install all over again using the Intel driver disk and "F6" Windows option again.

Part of the confusion here is that even with the Intel driver disk it is being installed as an Adaptec controller. Fine, I understand this may be licensed hardware, etc., however the Intel documentation explicity mentions the Intel Storage Matrix Utility.

I'll follow up a bit later this afternoon.
William K
Occasional Advisor

Re: Embedded SATA RAID on ML110

Well, I'm just about ready to consider purchasing a card to take care of this but I just can't give up on something that should work.

I've tried to follow all the helpful suggestions, links, etc. and still did not have success today. Before I give up I thought I'd try one last plea for assistance.

- If I setup the controller for RAID functionality prior to installing the O/S the system hangs during installation at the 'Windows setup' stage..... SO

- If I don't setup the controller for RAID prior to installing the O/S (and use the F6 function) the controller appears to be recognized but the setup proceeds without RAID functionality. Changing that after installation of the O/S obviously doesn't work.

- No matter which version of the Matrix Storage Manager I attempt to install I continue to get "incompatible version" messages.

So, any assitance:

- What state should I have the disks in within the BIOS prior to installing the O/S? (i.e. non - RAID setup)

- Controller is still recognized as an Adaptec product by the BIOS. Is this ok / correct? At the "F6" prompt it is recognized as an Intel device.

- Since the BIOS recognizes the SATA RAID should I configure the disks prior to installing the O/S and use the "F6" function to load the drivers? (This seems to freeze the setup)

- Should I be configuring the disks / RAID prior to the O/S installation and NOT use the F6 option since it is apparently already recognized by the BIOS? Would Windows recognize it without loading from the floppy?

Again, any help would be appreciated. I'm just about done trying to get this working...
Louis Vézina
Occasional Visitor

Re: Embedded SATA RAID on ML110

Your problem is that the firmware from the ARID controller is not up to date. You probably have this server since june 2005 or before and you have the 1.0 version of the BIOS. Update your bios to the current version and your RAID controller firmware will be updated at the same time. Ctrl-A is the keystroke used with the first version of the BIOS. The driver on the HP web site work only with the new firmware.

Good luck!
Louis Vézina
Occasional Visitor

Re: Embedded SATA RAID on ML110

You also need to enable the RAID controller in the BIOS, press F8 to go in the array manager and create your array. Finally, press F6 at the bigining of Windows 2003 installation and when prompted, insert the floppy disk(or USB key if you haven't a usb floppy drive) containing the driver you can get on this page:

http://h18023.www1.hp.com/support/files/server/us/download/23534.html