ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Enabling Proliant ML310E gen8 v2 Intel graphics (i3-4130)

 
benro2
Occasional Visitor

Enabling Proliant ML310E gen8 v2 Intel graphics (i3-4130)

Hi guys,

We have been lucky enough to inherit a Proliant ML310E gen8 v2 with Intel i3-4130 CPU, 16GB RAM.  We have managed to install Windows 10 on it, however it does not seem to pick up the Intel GPU within the CPU - and so instead, it is using the "Microsoft Basic Display Adapter" (the only entry underneath "Display Adapters" in Device Manager.

Attempting to install the Intel graphics driver for the i3-4130 doesn't work - an error is returned saying the computer doesn't meet their requirements.

Is there a BIOS setting or some other way to get it to detect the inbuilt Intel GPU, or install its driver?

Thanks!

3 REPLIES 3
ronissac
HPE Pro

Re: Enabling Proliant ML310E gen8 v2 Intel graphics (i3-4130)

WIndows 10 is not a supported OS on this server.

please refer  to the below document for reference on the support operating systems 

https://h20195.www2.hpe.com/v2/getdocument.aspx?docname=c04123183

Page 6

 

Ronny 

I am an HPE employee
Jimmy Vance
HPE Pro

Re: Enabling Proliant ML310E gen8 v2 Intel graphics (i3-4130)


@benro2 wrote:

Hi guys,

We have been lucky enough to inherit a Proliant ML310E gen8 v2 with Intel i3-4130 CPU, 16GB RAM.  We have managed to install Windows 10 on it, however it does not seem to pick up the Intel GPU within the CPU - and so instead, it is using the "Microsoft Basic Display Adapter" (the only entry underneath "Display Adapters" in Device Manager.

Attempting to install the Intel graphics driver for the i3-4130 doesn't work - an error is returned saying the computer doesn't meet their requirements.

Is there a BIOS setting or some other way to get it to detect the inbuilt Intel GPU, or install its driver?

Thanks!


The server uses the graphics that are part of iLO4 which is Matrox G200 based..  While Windows 10 isn't a supported OS, you might try one of the video drivers available for Windows Server versions for this server. Same goes for NIC and otehr componenets. 
Example video driver, you may need to extract the driver and manually update as the driver package may check OS versioning before it will install https://support.hpe.com/hpsc/swd/public/detail?sp4ts.oid=5379533&swItemId=MTX_c590362be5124d96ad98536e14&swEnvOid=4184#tab1

List of available drivers for this server https://support.hpe.com/hpesc/public/home/driverHome?pmasr=1&sp4ts.oid=5379533

 

 

No support by private messages. Please ask the forum! Accept or KudoI work for HPE
benro2
Occasional Visitor

Re: Enabling Proliant ML310E gen8 v2 Intel graphics (i3-4130)

Thanks for the help and explanation Jimmy!

We ended up getting a cheap GPU for it, plus have found some video drivers that work.

It is much nicer to use now, plus much quicker.

Thanks!