ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Error installing SP1 for W2K3 on HP ML 350 3G

Anders_33
Occasional Advisor

Error installing SP1 for W2K3 on HP ML 350 3G

Hi,

I am having trouble installing SP1 on one of my servers.

Hardware:
HP ML 350 3G with OEM version of W2K3

Problem:
The installation ends with an internal error.
the last thing that happends is checking product key just after "inspecting configuration"

From the svcpack.log file
------------------------------------
23.141: Trying CheckVLKForBlock again
24.109: Error: CheckVLKForBlock failed
24.109: Inventory complete: ReturnStatus=536741199, 17578 ticks
24.109: Num Ticks for invent : 17578
25.391: UnRegisterSpuninstForRecovery, failed to delete SpRecoverCmdLine value, error 0x2
25.391: DoInstallation: Failed to unregistering spuninst.exe for recovery.
25.391: An internal error occurred.
27.125: Message displayed to the user: An internal error occurred.
27.125: User Input: OK
27.125: Service Pack 1 installation did not complete.
28.375: Message displayed to the user: Service Pack 1 installation did not complete.
28.375: User Input: OK
28.375: Update.exe extended error code = 0x1ffe054f
28.375: Update.exe return code was masked to 0x643 for MSI custom action compliance.

I Have searched the internet and found some similar problems for XP SP2 but those sugestions found havn't worked for me...

Any help how go on with this problem would be grate!
9 REPLIES
Tv_3
Respected Contributor

Re: Error installing SP1 for W2K3 on HP ML 350 3G

Have you rebooted the machine before you had begun the installation, if not, try to reboot first, then relaunch SP1 again.

Have you enough diskspace?

Are you sure your SP1 download is not corrupt? Try a redownload perhaps.

Hope this helps.

greetzzz
Chaos, Panic or Disaster??? Always Stay Calm, I will fix it.
Anders_33
Occasional Advisor

Re: Error installing SP1 for W2K3 on HP ML 350 3G

Hi, yes I have rebooted several times and also installed new versions of the HP-software installed on the server like HP System Management agents.

The server uses SUS to get its updates and I doubt that these updates are corrupted since the SP1 has installed correctly on other servers also connected to SUS.

Are there any diffrences between the updates collected by SUS vs the updates downloaded directly from windows update?

Is there perhaps a special SP1 created by HP/compaq to use when using an OEM version of the windows server 2003?
Tv_3
Respected Contributor

Re: Error installing SP1 for W2K3 on HP ML 350 3G

Try to delete al temporary windows update cashed files?

Try a manual install.

greetzzz Tmy.


Chaos, Panic or Disaster??? Always Stay Calm, I will fix it.
Tv_3
Respected Contributor

Re: Error installing SP1 for W2K3 on HP ML 350 3G

Try to delete al temporary windows update cashed files.

Try a manual install.

greetzzz Tmy.


Chaos, Panic or Disaster??? Always Stay Calm, I will fix it.
Anders_33
Occasional Advisor

Re: Error installing SP1 for W2K3 on HP ML 350 3G

Ok, wehre exactly do I find thees cashed files?
Tv_3
Respected Contributor

Re: Error installing SP1 for W2K3 on HP ML 350 3G

The $$ file directories.within c:\winnt.

The windowsupdates and update folder under the program files and winnt directory.

All temporary internet files directories.

All temp directories.

etc...

Have you seen already this link:

http://v4.windowsupdate.microsoft.com/troubleshoot/

Perhaps your solution is somewhere in there.


Hope this helps. Let me know.

greetzzz.
Chaos, Panic or Disaster??? Always Stay Calm, I will fix it.
Anders_33
Occasional Advisor

Re: Error installing SP1 for W2K3 on HP ML 350 3G

I have tried you suggestions but nothing helps, same error.

What do you think of this Ide:

Slipstream SP1 into a standard win2k3 installation and then make an "repair" installation of current installation??

Do you know if SQL-server installations could be damaged by doing so?

Any help would be nice
/
Anders
Anders_33
Occasional Advisor

Re: Error installing SP1 for W2K3 on HP ML 350 3G

I solved the problem by using a slipstreamed w2k3 sp1 CD. Started the installation from within windows and choosed "uppgrade" wich is default. Took about 1,5 hours to complete the installation but it succeded with no errors!
Anders_33
Occasional Advisor

Re: Error installing SP1 for W2K3 on HP ML 350 3G

I solved the problem by using a slipstreamed w2k3 sp1 CD. Started the installation from within windows and choosed "uppgrade" wich is default. Took about 1,5 hours to complete the installation but it succeded with no errors!