ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Failure to install hprsm

 
Eddie Smith1
Advisor

Failure to install hprsm

Hello,

I'm trying to install
hprsm-7.5.0-169.rhel4.i386.rpm

on a
2.6.9-34.ELsmp #1 SMP Fri Feb 24 16:54:53 EST 2006 i686 i686 i386 GNU/Linux
Red Hat Enterprise Linux AS release 4 (Nahant Update 3)

Error"No Insight Management devices available"
Am I missing a package?

Preparing... ########################################### [100%]
Stopping HP Lights-Out Drivers and Agents (hprsm):

1:hprsm ########################################### [100%]
Please read the License Agreement for this software at

/opt/compaq/hprsm/hprsm.license

By not removing this package, you are accepting the terms
of the "License for HP Value Added Software".
Building custom cpqci driver
cpqci rebuilt, but failed to load.
No Insight Management devices available
(missing or disabled) on this system.
Please remove the hprsm package at your
earliest convenience (rpm -e hprsm).

==============================================================================
NOTE: New cma.conf entries were added to the top of /opt/compaq/cma.conf
==============================================================================
Starting HP Lights-Out Drivers and Agents (hprsm):

The hprsm RPM installation failed!
Installation failure may be due to incomplete or missing
build environment or to absent hardware (RILOE/RILOE II,
iLo/iLo 2). Please refer to the installation notes or to the
Linux Management HowTo available from http://www.hp.com/linux.
error: %post(hprsm-7.5.0-169.rhel4.i386) scriptlet failed, exit status 1



Thanks
9 REPLIES
sgunelius
Valued Contributor

Re: Failure to install hprsm

I found the following note: "The agents require an SNMP stack to be available. If SNMP support is not installed on the system, the agents will not load."

This may be a silly question, but do you have SNMP installed?
Eddie Smith1
Advisor

Re: Failure to install hprsm

Here are the installed snmp packages

net-snmp-libs-5.1.2-11.EL4.6
net-snmp-libs-5.1.2-11.EL4.6
net-snmp-5.1.2-11.EL4.6
David Claypool
Honored Contributor

Re: Failure to install hprsm

What platform hardware?
Eddie Smith1
Advisor

Re: Failure to install hprsm

This is for a BL35.
I have the same issue on a BL20
Bharath_Pingali
Trusted Contributor

Re: Failure to install hprsm

Hello ,

May be you should try installing the complete PSP package.

Sounds like hprsm needs some more packages to work.

-Bharath
Eddie Smith1
Advisor

Re: Failure to install hprsm

Bharath,

all the selections were chosen except the HBA driver upgrade.

I can post the log file if needed.
Oleg Koroz
Honored Contributor

Re: Failure to install hprsm

Bharath_Pingali
Trusted Contributor

Re: Failure to install hprsm

Hi,

There is a PSP 7.52 on www.hp.com.
I have PSP 7.52 installed on a BL45P ( Redhat 4 Update 3 ).

http://h18023.www1.hp.com/support/files/server/us/download/24759.html

Hope that works for you.

-Bharath
jwelling
Occasional Visitor

Re: Failure to install hprsm

Here's what I'm getting on an RHEL 4.0 box w/ the latest kernel and updates, and psp 7:

[root@cvbkup1 tmp]# rpm -Uvh ./mptlinux-3.02.56-14.rhel4.i686.
error: open of ./mptlinux-3.02.56-14.rhel4.i686. failed: No such file or directory
[root@cvbkup1 tmp]# rpm -Uvh ./mptlinux-3.02.56-14.rhel4.i686.rpm
Preparing... ########################################### [100%]
The currently running kernel (2.6.9-34.0.2.ELsmp) is not
supported by this rpm. The supported kernels are:

2.6.9-11.EL
2.6.9-11.ELhugemem
2.6.9-11.ELsmp
2.6.9-22.EL
2.6.9-22.ELhugemem
2.6.9-22.ELsmp
2.6.9-5.0.3.EL
2.6.9-5.0.3.ELhugemem
2.6.9-5.0.3.ELsmp
2.6.9-5.EL
2.6.9-5.ELhugemem
2.6.9-5.ELsmp

Please boot into a supported kernel before installing this rpm
error: %pre(mptlinux-3.02.56-14.i686) scriptlet failed, exit status 1
error: install: %pre scriptlet failed (2), skipping mptlinux-3.02.56-14
[root@cvbkup1 tmp]#

So it would appear HP is lagging in supporting the latest rhat kernel. It's killing me though because the scsi bus keeps resetting. We need the latest rhat for other fixes...