ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

G5 NC373i Performance issues

 
ChrisPSynergy
Occasional Contributor

G5 NC373i Performance issues

Hi,
We have a G5 with performance issues between 1000/100.

Anything via 1GB is fine - anything going to or from 100mb seems to be causing problems.

Is there anything which can be suggested?

I've got a few out of hours ideas to try but I am eager to know if there is anything anyone can suggest.

Thanks,

Chris
12 REPLIES
Kedd Guyton
Respected Contributor

Re: G5 NC373i Performance issues

Are you seeing anything out of the ordinary in the HP NCU (Network Configuration Utility) -> Properties -> Statistics -> Advanced? Any Overruns, CRC errors, Alignment errors, collisions, etcetera?

I see that you've listed the generation of server. Which model?

Which OS? x86 or x64?

Is the Speed/Duplex set to Auto/Auto?
ChrisPSynergy
Occasional Contributor

Re: G5 NC373i Performance issues

This was resolved.

Diagnostics revealed problems with the EEPROM and disableing TCP Offload has resolved the problem.

We are going to try new firmware and see if that resolves the issues.
CA1192176
Occasional Visitor

Re: G5 NC373i Performance issues

Was wondering if you got this resolved? We are seeing same ting, NC373i on DL385 G2 or DL380 G5 when Win 2003 and SP2 with PSP 7.9 and TOE enabled we get TOE erros and conncections fails, always seem to be when 1gb is talking to 100mb. 1gb to 1gb seems to work. Nice incentive to upgare entire network ;-)
nichol deaddis
Occasional Visitor

Re: G5 NC373i Performance issues

Hi Guys,

I'm experiencing pretty much the same issue here, difference is that I get random loss of connectivity (not reported by the NIC), my configuration is using 100Mb full duplex, same as switch. I have other servers with same specs and config on the same rack and I don't have any problems.
Any idea?

Cheers,
Kyösti Määttä
Occasional Visitor

Re: G5 NC373i Performance issues

Hi

I also have same kind of problem. My server is ML370 G5 with NC373i and it randomly (at least once a week) disappears from network. There is nothing informations in event logs. I have examined that it always happens when backup job over network begins at night and network traffic increases greatly. Does anyone knows if there is some kind of workaround (network adapter settings etc.). I have updated latest network firmware and MS drivers without any help. Both server adapter and switch port has been configured 100 Mbps/Full.


Mizzle
Occasional Visitor

Re: G5 NC373i Performance issues

There is an issue with certain nics and the TCP Offloading feature.

Please see the following article.

http://support.microsoft.com/kb/942861/en-us
Jamie Meyer
Occasional Visitor

Re: G5 NC373i Performance issues

I have a BL460C with a NC373i NIC which becomes unresponsive to network connections about once a week (seemingly at random.) It has to be rebooted to bring it back online. This behavior usually is accompanied by 8021 and 8032 errors in the system log. Do you think it could be related to the offload "feature" mentioned in this thread?
Rick Behrens
Occasional Visitor

Re: G5 NC373i Performance issues

I am having issues also with HPNC373i nic card speed being 4 times slow to upload large SQL tables than a Dell NIC card. Besides changing the three registry's setting to 0,
EnableRSS = 0
EnableTCPA = 0
EnableTCPChimney = 0

Once we changed the NIC card setting to
Checksum Offload = NONE
Large Send Offload = DISABLE
Receive Side Scaling = DISABLE
The speed was doubled. Still looking at firmware or HP NCU utility to increase it more.
Speigel
Occasional Visitor

Re: G5 NC373i Performance issues

Hi Chris,

In one of your comment on this forum you said that diagnostic revealed that EEPROM has the problem with TOE features. What test did you do to come to conclusion that EEPROM has the problem and how?

We have DL360 G5 serevrs is production which has connectivity issues from client after weekly reboot. The NIC used to connect to the client is NC373i. We are trying to reproduce the issue but with no luck. Also we see lots of CRC/frame errors on the switch port connected to this NIC. Any help is much appreciated. Thank you.

Regards,
Andrew Catchpole
Occasional Visitor

Re: G5 NC373i Performance issues

I have same problem on 6 HP Servers with NC373i NICS

The application is really suffering even though ping show 100% network relaibility with 2ms rtt.

However, netstat -s shows up to 5% TCP retransmission. No wonder the application is suffering!!!

HP support have done all pacthing and I have turned off TOE and RSS. netstat -t shows no off-loading (to NIC).

BUT the problem has not gone away.

Any help appreciate!!!!
Robin Hotter
Occasional Advisor

Re: G5 NC373i Performance issues

Andrew,

I would suggest updating the firmware on the card.

Also check what version of C:\windows\system32\drivers\Storport.sys you have on your machine. The Windows Server 2003 SP2 Enterprise machine I had problems with was running v5.2.3790.3959.

This file has something to do with the way the NC373i HP Virtual bus device functions. After some searching I found this link to a newer Storport.sys file :

http://support.microsoft.com/kb/957910

In then end the steps i took that worked were:

1) Upgrade the NIC firmware
2) Install the newer storport.sys file from Microsoft.
3) Reboot
4) Run cp009681.exe (from http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01684544〈=en&cc=us&taskId=101&prodSeriesId=428936)
5) Then install the newer NIC driver and NCU (i did this via the Blade Online Firmware Bundle v1.60 - but you should be able to do it using the PSP install or manually).
6) Reboot and it worked for me.

Hope this may help.
Rob
João Ribeiro
Occasional Visitor

Re: G5 NC373i Performance issues

Hi everyone,

I'm having pretty much the same problem.

I have a HP server with an NC373i nic running SQL server and File server.

About a month ago we noticed that the SQL Server was becoming dead slow over the network.

After some reading I set the NIC to 100/FULL (despite the server has worked for over 2 years in Auto/Auto mode) which didn't solve the problem but made it a lot better.

The file transfers between our HP server and the other workstations are our main issue now. To get a 2GB file from the server it takes more than 200 minutes...

We noticed this problem (slow speed) in both directions (Tx and Rx).

We have the server fully updated (both firmware and drivers) and done all the suggestions above with no luck at all.

We also tried changing the RJ45 cable also with no results.

Any other idea??

Thanks