ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

G6s won't boot to virtual media through iLO 2?

BDay
Frequent Advisor

G6s won't boot to virtual media through iLO 2?

I'm trying to load our OS from remote through iLO 2 w/Advanced Feature Pack enabled and am having a tough time. No matter what boot order I try in the BIOS the server will not boot from any virtual media.

It just goes through the basic..

Attempting to Boot from CD-ROM
Attempting to Boot from Floppy
Attempting to Boot from Harddrive
Attempting to Boot from Network

...then goes into a reboot loop even though the virtual media applet shows I am connected to the server.

Due to pre-existing security policies I had to change iLO to use port 3000 for the virtual media feature, could this cause a problem?

The one I am currently trying to install on is;

DL360 G6
BIOS P64
iLO 2 1.77 (Adv Feature Pack Licensed)

I'm getting the same behavior on all of the 360s and 380s we just bought.

If I go to the server and put the USB key with smart start on it in the server itself or a DVD of the same smart start image it boots to it just fine.

Thoughts?
12 REPLIES
BDay
Frequent Advisor

Re: G6s won't boot to virtual media through iLO 2?

FYI.. my desktop is Server 2008 R2 Build 7100 if that matters. It has Java 6U13 installed.
Michal Kapalka (mikap)
Honored Contributor

Re: G6s won't boot to virtual media through iLO 2?

hi,

what about your firewall setting ???

mikap
BDay
Frequent Advisor

Re: G6s won't boot to virtual media through iLO 2?

Sorry I should have mentioned that. It is disabled.
Michal Kapalka (mikap)
Honored Contributor

Re: G6s won't boot to virtual media through iLO 2?

hi,

thats ok, actually we dont have any G6 proliants in our datacenter, but i saw some strange issues regarding IE8.

mikap
BDay
Frequent Advisor

Re: G6s won't boot to virtual media through iLO 2?

I was going to start another thread once I got this figured out, but since you brought up IE8 I've so far been unable to use the integrated console as I get no keyboard responses in it so I'm using the java one.

Maybe I need to fire up a trusty XP virtual machine and see how it works with IE7 and go from there. :)
Michal Kapalka (mikap)
Honored Contributor

Re: G6s won't boot to virtual media through iLO 2?

hi,

yes the XP is in my opinion the best desktop os from MS, but i use only a linux and the Windows is inside a virtual machine ( lot of software for storage/management are ported only for Windows platform ).

mikap
rick jones
Honored Contributor

Re: G6s won't boot to virtual media through iLO 2?

I have had success doing vMedia installs of RHE 5.3 and SLES11 onto BL460 G6's with a laptop running Ubuntu Jaunty Jackalope. (Using the "plain" Remote Console of course :)
there is no rest for the wicked yet the virtuous have no pillows
JKytsi
Honored Contributor

Re: G6s won't boot to virtual media through iLO 2?

Stupid question maybe but are You sure that your media is bootable ?
Remember to give Kudos to answers! (click the KUDOS star)

You can find me from Twitter @JKytsi
Diego Castelli
Trusted Contributor

Re: G6s won't boot to virtual media through iLO 2?

i Quote Jarkko.

I would try this way:

Try to boot from the media on your PC: it could be not bootable.

Try to boot from the media from an (old enough) CD/DVD Drive: it could be written too fast, if it isn't original media, to work with virtual media. I had this problem too in the past. OR, if you can, directly try writing the CD again slower.

If everything's OK with the media:

Try to use virtual media from IE7 or 6.

Try to restore the default ports (if you can, even for a bit)

Try to upgrade the ILO2 FW.

If everything fails, contact HP.
Diego C.

MS MCSA Server 2003

HP Accredited Integration Specialist
BDay
Frequent Advisor

Re: G6s won't boot to virtual media through iLO 2?

Yes, the media is bootable. If I walk down to the server room and stick it in the server it boots it fine. I'll try upgrading one of them to 1.78 today and see if it helps. I built an XP VM yesterday with IE7 instead of IE8 to test with so hopefully I can get to it today. :)
Val1976
Occasional Visitor

Re: G6s won't boot to virtual media through iLO 2?

In order to boot from virtual CD you have to set the following configuration on server BIOS:

 


USB control ----- Eternal USB ports disabled.
USB 2.0 COntroller ------ Disabled

 

That works for me.

 

Regards.

AlexZZZ
Occasional Visitor

Re: G6s won't boot to virtual media through iLO 2?

Thanks!!! That works for me too... :)