ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Gigabit network cards affecting group policy

 
Michael Paul_3
Occasional Visitor

Gigabit network cards affecting group policy

Hi I have various DL380's, ML350's and DL140's with the client workstations being dc5000's. They all have gigabit nics plugged into Cisco Catalyst switches. The workstations are plugged into 10/100 switches and the servers are plugged into a gigabit switch. I had a 3 hour call with Microsoft and at the end of it we discovered the following.

If we left the switch at auto for speed and duplex and the workstation/server at auto, the group policy would not apply. If we hard coded the speed on the switch to 100/Full and hard coded the NIC on the workstation/server to 100/Full, the group policy would apply.

Since the NIC card only has the following settings, 10/half, 10/full, 100/half, 100/full, AUTO, if I am plugged into a gigabit switch I have to pick auto, my policy does not apply. There is no setting for 1000/half, 1000/FULL. I have pulled the latest Compaq support paq and applied to the servers in question and the driver on the workstation is the latest off the website.

My question is two fold, what could be some reasons why the hard coding of the NIC is required for the application of the group policy? Why is there no setting for 1000/FULL?

The cisco switches have spanning-tree portfast turned on, except to other switches.

The NIC's are the on-board Broadcom gigabit nc76XX for the servers and a broadcom NetXteme for the workstations.

Thanks in advance.
2 REPLIES
Terry Hutchings
Honored Contributor

Re: Gigabit network cards affecting group policy

There hasn't been an option to change the nic to 1000/full, since this isn't included in the spec for gigabit ethernet. This has been included in the newer version of the drivers. The embedded nics in the DL380 G3s and the ML350 G3s are using the NC77XX driver. I'm not sure about the workstations, but version 7.74.0.0 (one version back) includes the option to hard set 1000/full as an option.

The only thing I can see is it's possible there's some instability caused the switch and/or nics when set to auto.
The truth is out there, but I forgot the URL..
Michael Paul_3
Occasional Visitor

Re: Gigabit network cards affecting group policy

Thanks for your reply. I just looked at those drivers. That'll help for the servers thanks.

The workstations will all be plugged into 100 mb ports so I'll just hard code them to 100 Full.

It's so strange. I retested again yesterday but with a server that isn't in production yet. The minute I hard code the speed the duplex at 100Full that policy comes up no problem. Immediately when I change it back to auto, the policy doesn't even come up.