ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

HELP! error 212 Processor 1 failed.

 
Ayman Altounji
Valued Contributor

HELP! error 212 Processor 1 failed.

Well I dunno whats happened ive had my server for the past couple of months and its run windows 2k/redhat 6.2/7.3 and I was installing redhat8.0 lastnite and during the install I had to go out, I returned and the install was almost complete - the machine was a little sluggish and then i rebooted after the install had finished and it, came up with a 212 error... I have not added/removed any hardware from the machine and I swap the processors round and it still fails processor 1...

the processors are pentium II (mmx) 450mhz and I have 512mb of ram in dimm1... I have no idea why its just packed it in -- other then age, so some ideas would be helpful...
4 REPLIES
Ayman Altounji
Valued Contributor

Re: HELP! error 212 Processor 1 failed.

Hi, you could run the server diag to confirmed the processor failure since that most likely the problem. You could also try the system board firware update.
Don Croswell
Occasional Visitor

Re: HELP! error 212 Processor 1 failed.

Hello All you fellow newbies

I own a Compaq Priliant 2500 with dual processors. I tried to install an OS that somehow disabled my second processor. And gave me the error '212-Processor failed'.

As this machine is old, I thought maybe she had just packed it in but tried to fix the problem with my limited knowledge.

First I did an search on the 212 error and found lots of people with the same problem but no replies or replies that said to buy a new board.

I swapped the power supplies around and got the same '212-Processor failed' error on processor number 2 so I knew it wasn't the power supply.

I swapped the actual processors to confirm that they both worked....and they did.

I called up the HP/Compaq tech support and they were very helpful. They suggested that I 'FLASH' the bios, and if that didn't work, then I needed a new motherboard. $1500!!

Being the newbie that I am, I went to the HP site and downloaded the ROMPAQ file(SP19742.exe) onto a disk and followed the instructions on flashing the bios or "firmware"

When I booted the system back up I still got the error.

I called the HP people again and the next guy suggested that I turn on switch #6 on SW1 on the mother board, then turn on the machine.......error.......turn off the machine......switch #6 back off.......turn on machine. For those of us who have no idea what those switches do, or where they are, they are inside the computer on the motherboard. Six tiny switches that u need tweezers to switch on and off. Have a look and you will find them.

When I booted back up, I still got the error so I called again. The last guy said that all options had been used and I just needed to buy a new board.

Disappointed I thought what the hell, I'll turn off all of my switches and then turn them all on just to see what happens. I followed the same procedure as before and when I had booted up again with all of the switches back off, the system asked for a 'System Configuration Utility'.

Back to Google and the HP site. Another call to the HP people and I had a new file (SP13227.exe) which would be spread accross 4 floppies.

Reboot with floppy number 1 and I got the 212-Processor error but under it was the addition '172-EISA Configuration Nonvolatile Memory Invalid.'

Then booted again and SCU Utility asked for the CFG File: !CPQ0551.cfg

**********************************************************************************************
This is where I think things started to go my way
**********************************************************************************************

Yet another search and call to HP. The last guy I spoke to asked me if the Bios flash file I downloaded was the same 'version' as the SCU (System Configuration Utility).

He then proceeded to give me two fresh SP files on the HP site. One for the bios flash (SP14127.exe one floppy) and one for the SCU (SP19619.exe four floppies). He said 'IT IS IMPORTANT THAT THEY MATCH'.

Again I booted up with the ROMPAQ bios flash.

Then when I booted with the SCU disk #1, It asked me if the second processor was fixed. I said yes. Power off, power on with SCU disk #1 still in the floppydrive.

Then asked for CFG file on floppy #2. Inserted #2 'enter'.

Reboot and guess what.....both processors were initialized and working.

The thing that I am putting my success down to is the fact that both files had to match and I just kept trying.

Maybe some of you will think what an idiot but I am writting this with the hopes that I can save some newbie out there the trouble and $ of buying a new board (I had three HP tech people, not sales people, tell me that is what I needed)

Good luck!!
Jim Kuo
Occasional Visitor

Re: HELP! error 212 Processor 1 failed.

212 Processor error message typically represent a processor failure/pre-failure. You will usually get this message during initial ROM boot up when BIOS checked and indicated a potential processor problem. You should run the DIAGNOSTIC utility and see if you do have a processor failure. Once the failed processor is replaced, you need to access ROM-Based-Setup-Utility (RBSU) (or system configuration utilty (SCU)on older generation ProLiant boxes) and correct the failure. There should be an entry in RBSU indiciating that you have fixed the failed processor. The same entry also exist in SCU as an advanced configuration entry.
Once you indicate that the processor is fixed, the message should be removed.
Leslie Bester
Occasional Visitor

Re: HELP! error 212 Processor 1 failed.

Hi there.

I've had a similar problem using RedHat 9.0 and a Proliant 850R.

I have a number of 850R's. Some work with SMP, some do not.

The 212-Processor Failed error was common after reboots to all the systems where SMP failed.

The solution for me, was to run the setup utility, select view/modify hardware configuration.

Then, select Operating System, choose UNIX, then set LINUX.

My previous selections were OTHER.

Once I set the O/S to UNIX->LINUX, it worked perfectly after many reboots, where the previous configuration would fail reliably.