ProLiant Servers (ML,DL,SL)

HP-AMS & HP-HELATH - will there be a release for Ubuntu 20.04 LTS?

 
dchard
Advisor

HP-AMS & HP-HELATH - will there be a release for Ubuntu 20.04 LTS?

Hi,

I am pleased to see that the MCP repository now has Ubuntu 20.04 (focal) in the support list.

My question would be if we will see the HP-AMS also getting a release for Ubuntu 20.04 LTS as well?

I ams using hp-ams (2.8.3), hp-health (10.80) and hponcfg (5.5.0.0.-1) on a gen8 server, and when I navigate to the ILO4 --> System Information --> Software field, the Installed Software is stuck in "Loading..." state, and after a minute or so, the ILO4 webgui drops an error:

HP-AMS_ilo4_gen8_error.pngHP-AMS_ilo4_gen8.png

4 REPLIES 4
Tech_Aniket
HPE Pro

Re: HP-AMS & HP-HELATH - will there be a release for Ubuntu 20.04 LTS?

Hello dchard,

Thank you for posting your query.

The Latest MCP repository pack released are for newer generation of HPE Server like Gen10 Servers and health/snmp functionality was moved to the iLO card on HPE ProLiant Gen10 servers.

This MCP repository pack includes HPE AMS inside the package.

 

For MCP repository details please refer to - https://downloads.linux.hpe.com/SDR/project/mcp/

NOTICE:  The health/snmp functionality was moved to the iLO card on HPE ProLiant Gen10 servers. The hp-health, hp-snmp-agents, hp-smh* and hp-ams debs are only to be installed on Gen9 servers and earlier.  Gen10 users, please subscribe to "11.xx" or "current" repositories. Gen9 users, please use "10.xx" or earlier.

 

Thank you

 

Regards,

Aniket Chauhan

 

 

I am an HPE Employee

Accept or Kudo

dchard
Advisor

Re: HP-AMS & HP-HELATH - will there be a release for Ubuntu 20.04 LTS?

Hi,

Yes I know how to install the packages, as you see my first post, I already did.

The prolem is that the latest "hp-ams" package is from 2019. February, and the "focal" release does not even contain it. I installed it manually, but as you can see: it does not work properly even with ILO4 (I am not even trying to use it via SNMP yet).

So the question is, when we will see Ubuntu 20.04 LTS support for hp-ams and hp-health? (gen8 and gen9).

 

KM26
HPE Pro

Re: HP-AMS & HP-HELATH - will there be a release for Ubuntu 20.04 LTS?

Hi,

Good day!

We have no ETA for the release of Ubuntu 20.04, thus we cannot comment on its contents.

The last available version as per the HPE website is 18.04.

Management Component Pack for Ubuntu 18.04 LTS

https://internal.support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_5b1a9cd500eb4b3eb2783cff27#tab-history

 

Thank You!
I am an HPE Employee

Accept or Kudo

cberni
Occasional Contributor

Re: HP-AMS & HP-HELATH - will there be a release for Ubuntu 20.04 LTS?

Hi!

I'm having the same problem. Ubuntu 20.04 (focal) and no MCP realeases for Gen9 and earlier (10.xx).

I have several Gen9 and earlier HP servers. I tried to use Ubuntu 18 (bionic) pakages but didn't work. Seens to have conflic with snmpd version. Bionic is 5.7 snmpd version and Focal is 5.8.

Will be any chances to have Ubuntu 20.04 (focal) release for MCP to Gen9 and earlier HP servers?

we need to install the "hpsmh"