ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

HP DL 380 G5 - SLB

 
hpabc
Advisor

HP DL 380 G5 - SLB

Hi,

We have 2 NICs on HP DL 380 G5 server running Win2K3-R2. I want to configure SLB for same. Drivers are updated to the latest.

I connected both the NIC to Cisco 3560G-L3 switch. I selected the SLB option in the HP Network conf utility with all defaults.

Switch is configured as below for both ports,
config t
interface range 0/19 - 20
no ip address
no switchport
channel-group 10 mode on
end

config t
port-channel load-balance src-dst-ip
end

I am not able to connect to the server. Ping does not work.

Please guide what could be the cause and troubleshoot.

Thanks,

Sid.
4 REPLIES
venkat81
Occasional Advisor

Re: HP DL 380 G5 - SLB

Hi SId

While enabling the SLB in the Network Configuration utility you can enable the SLB either using the layer 2 or layer 3. try enabling the layer 2 that is instead of ip address configure load balancing using the mac address on both sides and check.

hpabc
Advisor

Re: HP DL 380 G5 - SLB

Hi,

I tried to configure it as below,

config t
port-channel load-balance src-dst-mac
end

config t
interface range gig 0/19 - 20
switchport
switchport mode access
channel-group 10 mode on

At the channet-group command i get the error as -

Command rejected (Port-channel10, Gi0/19): Either port is L2 and port-channel is
L3, or vice-versa

% Range command terminated because it failed on GigabitEthernet0/19

Please guide

Thanks,

Sid.
hpabc
Advisor

Re: HP DL 380 G5 - SLB

Hi

I skipped to add the vlan on that ports. After adding the ports to vlan, i am able to communicate with the server !!! :P

But i am not able to set the channel-group option.
I can configure channel-group only with "no switchport" option. With that command i am not able to add the port in its vlan.

The configuration now is as below

interface range 0/19 - 20
switchport access vlan 101
switchport mode access

Please guide.

Thanks,

Sid.
hpabc
Advisor

Re: HP DL 380 G5 - SLB

Hi,

The problem is resolved. The channel-group 10 was L3. Creating a new channel-group 20, L2, resolved it. The configuration now is -

config t
port-channel load-balance src-dst-ip
end

config t
interface range gig 0/19 - 20
no ip address
switchport mode access
switchport access vlan 101
channel-group 20 mode on
end

Thanks

Sid.