ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

HP DL370G6 - Windows failed to start \Boot\BCD 0x000000f

 
SOLVED
Go to solution
hpeuser1
Occasional Visitor

HP DL370G6 - Windows failed to start \Boot\BCD 0x000000f

Hello,

I have a HP DL370 G6 server running Windows Server r2008 R2 as a Hyper-V HOST that, after a reboot, will not boot anymore. We're getting Windows failed to start \Boot\BCD 0x000000f -- An error occured while attempting to read the boot configuration data. I have booted into the recovery console and tried the usual bootrec /fixboot, bootrec /fixmbr, bootrec /rebuildbcd. The first two commands "completed successfully" but /rebuildbcd gives:

Succcessfully scanned Windows installations.
Total identified Windows installations: 1
[1] C:\Windows
Add installation to boot list? Yes(Y)/No(N)/All(A):y

The requested system device cannot be found.

chkdsk says everything is good.
sfc /scannow says everything is good (after starting the "TrustedInstaller" service) - before starting the service I was trying sfc /scannow /offbootdir=c:\ /offwindir=c:\windows but getting the error "Windows Resource Protection could not perform the requested operation".

I also read somewhere when trying to use bcdedit that if the system is running x64, but the cmd is x86 (running from \Windows\SysWOW64). I tried "\Windows\sysnative" but no matter what, I get:

C:\Windows\System32>bcdedit /enum
The boot configuration data store could not be opened
The requested system device cannot be found

C:\Windows\System32>bcdedit
The boot configuration data store could not be opened
The requested system device cannot be found


Onnnnn to DISKPART now. When I issue the list vol command, I don't see any partitions LABELED WITH System or Boot, almost like my entire boot partition has disappeared! I'm used to seeing the System partition being very small (~500 MB), but all I have are my larger drives (C (operating system), D (partition for VM VHD's), E (DVD-ROM)).

I understand the Boot volume can be large -- on my Windows 10 computer I have C as my Boot volume (49 GB), but my System partition is only 549 MB, and under the "Info" column in DISKPART --> list vol it is reporting "System". I don't see System or Boot on my HP DL370G6 anywhere.

If I go into the HP "Boot Disk Test" it tells me:
Boot Disk Status: Pass - Disk Present
Boot Disk Ready: Pass - Disk Ready
Verify Boot sector: Fail - Valid OS Boot Sector Not Present

-------------------------------------------------------------------------------

If I boot from System Recovery, get all the way into "System Recovery Options" where it says:

"Select an operating system to repair and click Next. Note: This feature cannot repair operating systems earlier than Windows Vista.

There is NO OPERATING SYSTEM PRESENT. So, I tread through HP's websites to find my driver for the HP Smart Array P410i Controller, and found it. I loaded the drivers and when I saw my RAID controller, I was very very excited, thinking alas, when I click Add Drivers..., I will finally "see" my OS and this System Recovery tool can do its thing. My OS never shows up. :(

As you can imagine, I am at a loss and that is why I am here. Hopefully someone has run into this and knows of some kind of solution or recommendation.

Many thanks in advance!

2 REPLIES 2
BPSingh
HPE Pro
Solution

Re: HP DL370G6 - Windows failed to start \Boot\BCD 0x000000f

Greetings!

Sorry to know about the situation and I hope you already have valid data backed up before the issue occurred.  

I see that you have alreaady tried to Repair MBR:

You may try rebuilding a new BCD check with alternate method to rebuild MBR as mentioned on below link:

https://www.disk-partition.com/articles/windows-failed-to-start-file-boot-bcd-3889.html  

 

 

 

 

I am a HPE Employee
hpeuser1
Occasional Visitor

Re: HP DL370G6 - Windows failed to start \Boot\BCD 0x000000f

Hi @BPSingh, many many thanks for posting that link!!!! On that page, is the first time I've ever seen the bootrec /scanos command. EVERYWHERE else I've seen online only shows the three:

bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd

I am not sure if this is what finally got the bootrec /rebuildbcd command to actually succeed without The requested system device cannot be found error, but in any case I was able to get the server to boot. When I did, the VMs wouldn't start, but the "fix" for that is at the very bottom. Ultimately, these are the commands (in bold) that I issued in order to get it to boot (albeit in the span of about six hours while troubleshooting online):

Used DISKPART to make C "active", rebooted back into recovery:
DISKPART
list disk
list vol
select disk 0
select vol 1
active

bootrec /fixmbr
bootrec /fixboot
bootrec /scanos
bootrec /rebuildbcd <-- for the first time that actually worked! but also first time ever seeing/issueing the scanos command above

At this point I was now getting a different STOP code -- 0xc00000e9 - Windows failed to load because the system registry file is missing, or corrupt.

Also for the first time, System Recovery was now able to see my "C" OS partition, even though I didn't even have to load the SmartArray p410i controller drivers.

then deleted and rebuilt bcd store at \Boot\BCD:
attrib -r -s -h C:\boot\bcd
del c:\boot\bcd
bcdboot c:\windows

then ran:
chkdsk /f /r
it found errors and fixed
then ran
sfc /scannow
rebooted

...to get VMs running was:
bcdedit /set hypervisorlaunchtype auto

 

DISKPART NOW SHOWS:
DISKPART> list vol

  Volume ###  Ltr  Label        Fs     Type          Size     Status        Info
  ----------  ---  -----------  -----    ----------    -------  ---------     ------
  Volume 0     D                             DVD-ROM       0 B  No Media
  Volume 1     C                    NTFS     Partition  219 GB  Healthy       System
  Volume 2     F   VHDs       NTFS     Partition      8 TB  Healthy

I've rebooted the server many times since getting it working again.... should I be worried I don't see Boot under the Info column for any of the volumes?